summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index da4d7fac..b87a7474 100644
--- a/Makefile
+++ b/Makefile
@@ -226,14 +226,23 @@ test: $(TARGETS) $(EXTRA_TARGETS)
cd tests/techmap && bash run-test.sh
cd tests/memories && bash run-test.sh
cd tests/sat && bash run-test.sh
+ @echo ""
+ @echo " Passed \"make test\"."
+ @echo ""
VALGRIND ?= valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes --errors-for-leak-kinds=all
vgtest: $(TARGETS) $(EXTRA_TARGETS)
$(VALGRIND) ./yosys -p 'setattr -mod -unset top; hierarchy; proc; opt; memory -nomap; opt -fine; techmap; opt' $$( ls tests/simple/*.v | grep -v repwhile.v )
+ @echo ""
+ @echo " Passed \"make vgtest\"."
+ @echo ""
vloghtb: $(TARGETS) $(EXTRA_TARGETS)
cd tests/vloghtb && bash run-test.sh
+ @echo ""
+ @echo " Passed \"make vloghtb\"."
+ @echo ""
install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)/bin