summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 29c6113f..6dde27a9 100644
--- a/Makefile
+++ b/Makefile
@@ -226,6 +226,11 @@ test: $(TARGETS) $(EXTRA_TARGETS)
cd tests/memories && bash run-test.sh
cd tests/sat && bash run-test.sh
+VALGRIND ?= valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes --errors-for-leak-kinds=all
+
+vgtest: $(TARGETS) $(EXTRA_TARGETS)
+ $(VALGRIND) ./yosys -p 'setattr -mod -unset top; hierarchy; proc; opt; memory -nomap; opt -fine; techmap; opt' $$( ls tests/simple/*.v | grep -v repwhile.v )
+
vloghtb: $(TARGETS) $(EXTRA_TARGETS)
cd tests/vloghtb && bash run-test.sh