summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 38e89213..8d2e7679 100644
--- a/Makefile
+++ b/Makefile
@@ -143,6 +143,13 @@ ifeq ($(ENABLE_COVER),1)
CXXFLAGS += -DYOSYS_ENABLE_COVER
endif
+define add_share_file
+EXTRA_TARGETS += $(1)/$(notdir $(2))
+$(1)/$(notdir $(2)): $(2)
+ $$(P) mkdir -p $(1)
+ $$(Q) cp $(2) $(1)/$(notdir $(2))
+endef
+
ifeq ($(PRETTY), 1)
P_STATUS = 0
P_OFFSET = 0