summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 79220486..a84a787d 100644
--- a/Makefile
+++ b/Makefile
@@ -83,6 +83,11 @@ yosys-svgviewer: libs/svgviewer/*.h libs/svgviewer/*.cpp
cd libs/svgviewer && qmake-qt4 && make
cp libs/svgviewer/svgviewer yosys-svgviewer
+abc:
+ test -d abc || hg clone https://bitbucket.org/alanmi/abc abc
+ cd abc && hg pull && make
+ cp abc/abc yosys-abc
+
test: yosys
cd tests/simple && bash run-test.sh
cd tests/hana && bash run-test.sh
@@ -91,6 +96,9 @@ test: yosys
install: $(TARGETS)
install $(TARGETS) /usr/local/bin/
+install-abc:
+ install yosys-abc /usr/local/bin/
+
clean:
rm -f $(OBJS) $(GENFILES) $(TARGETS)
rm -f libs/*/*.d frontends/*/*.d passes/*/*.d backends/*/*.d kernel/*.d
@@ -128,6 +136,6 @@ config-gprof: clean
-include backends/*/*.d
-include kernel/*.d
-.PHONY: all top-all test clean mrproper qtcreator
+.PHONY: all top-all abc test install install-abc clean mrproper qtcreator
.PHONY: config-clean config-clang-debug config-gcc-debug config-release