summaryrefslogtreecommitdiff
path: root/backends/smt2/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'backends/smt2/Makefile.inc')
-rw-r--r--backends/smt2/Makefile.inc14
1 files changed, 14 insertions, 0 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index 4e0a393a..65cb6e3d 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -1,3 +1,17 @@
OBJS += backends/smt2/smt2.o
+ifneq ($(CONFIG),mxe)
+ifneq ($(CONFIG),emcc)
+TARGETS += yosys-smtbmc
+
+yosys-smtbmc:
+ $(P) sed '3 { p; s|.*|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|; }' \
+ < backends/smt2/smtbmc.py > yosys-smtbmc.new
+ $(Q) chmod +x yosys-smtbmc.new
+ $(Q) mv yosys-smtbmc.new yosys-smtbmc
+
+$(eval $(call add_share_file,share/python3,backends/smt2/smtio.py))
+endif
+endif
+