summaryrefslogtreecommitdiff
path: root/backends/smt2/Makefile.inc
diff options
context:
space:
mode:
Diffstat (limited to 'backends/smt2/Makefile.inc')
-rw-r--r--backends/smt2/Makefile.inc9
1 files changed, 4 insertions, 5 deletions
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
index 65cb6e3d..be52ca89 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -5,11 +5,10 @@ ifneq ($(CONFIG),mxe)
ifneq ($(CONFIG),emcc)
TARGETS += yosys-smtbmc
-yosys-smtbmc:
- $(P) sed '3 { p; s|.*|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|; }' \
- < backends/smt2/smtbmc.py > yosys-smtbmc.new
- $(Q) chmod +x yosys-smtbmc.new
- $(Q) mv yosys-smtbmc.new yosys-smtbmc
+yosys-smtbmc: backends/smt2/smtbmc.py
+ $(P) sed '3 { p; s|.*|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|; }' < $< > $@.new
+ $(Q) chmod +x $@.new
+ $(Q) mv $@.new $@
$(eval $(call add_share_file,share/python3,backends/smt2/smtio.py))
endif