summaryrefslogtreecommitdiff
path: root/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch')
-rw-r--r--debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch b/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
index 9ffefdbc..0b46c4a0 100644
--- a/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
+++ b/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
@@ -7,14 +7,14 @@ Subject: Fix adding of sys.path in yosys-smtbmc
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
-index eacda27..f98e610 100644
+index dce82f0..f98e610 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
@@ -6,7 +6,7 @@ ifneq ($(CONFIG),emcc)
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
-- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(__file__) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
+- $(P) sed 's|##yosys-sys-path##|sys.path += [os.path.dirname(os.path.realpath(__file__)) + p for p in ["/share/python3", "/../share/yosys/python3"]]|;' < $< > $@.new
+ $(P) sed 's|##yosys-sys-path##|sys.path += ["/usr/share/yosys"]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@