summaryrefslogtreecommitdiff
path: root/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch')
-rw-r--r--debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
index 2389eb85..a62c7d26 100644
--- a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
+++ b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
@@ -7,10 +7,10 @@ Subject: Let dpkg-buildpackage handle stripping of binaries
1 file changed, 4 deletions(-)
diff --git a/Makefile b/Makefile
-index b169eb7..961e2ce 100644
+index 6801a59..0a75c58 100644
--- a/Makefile
+++ b/Makefile
-@@ -612,19 +612,15 @@ install: $(TARGETS) $(EXTRA_TARGETS)
+@@ -730,20 +730,16 @@ install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(BINDIR)
$(INSTALL_SUDO) cp $(TARGETS) $(DESTDIR)$(BINDIR)
ifneq ($(filter yosys,$(TARGETS)),)
@@ -25,8 +25,9 @@ index b169eb7..961e2ce 100644
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(DATDIR)
$(INSTALL_SUDO) cp -r share/. $(DESTDIR)$(DATDIR)/.
ifeq ($(ENABLE_LIBYOSYS),1)
- $(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)
+ $(INSTALL_SUDO) mkdir -p $(DESTDIR)$(LIBDIR)
+ $(INSTALL_SUDO) cp libyosys.so $(DESTDIR)$(LIBDIR)/
- $(INSTALL_SUDO) $(STRIP) -S $(DESTDIR)$(LIBDIR)/libyosys.so
- $(INSTALL_SUDO) ldconfig
- endif
-
+ ifeq ($(ENABLE_PYOSYS),1)
+ $(INSTALL_SUDO) mkdir -p $(PYTHON_DESTDIR)/pyosys
+ $(INSTALL_SUDO) cp libyosys.so $(PYTHON_DESTDIR)/pyosys/