summaryrefslogtreecommitdiff
path: root/debian/patches/manual-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/manual-build.patch')
-rw-r--r--debian/patches/manual-build.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/patches/manual-build.patch b/debian/patches/manual-build.patch
new file mode 100644
index 00000000..dd3d2030
--- /dev/null
+++ b/debian/patches/manual-build.patch
@@ -0,0 +1,23 @@
+From: Sebastian Kuzminsky <seb@highlab.com>
+Date: Sat, 14 May 2016 15:44:13 +0200
+Subject: build the manual using the headers from the source tree,
+ not the installed ones.
+
+===================================================================
+---
+ manual/PRESENTATION_Prog/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/manual/PRESENTATION_Prog/Makefile b/manual/PRESENTATION_Prog/Makefile
+index 794f5c1..319909c 100644
+--- a/manual/PRESENTATION_Prog/Makefile
++++ b/manual/PRESENTATION_Prog/Makefile
+@@ -2,7 +2,7 @@
+ all: test0.log test1.log test2.log
+
+ my_cmd.so: my_cmd.cc
+- ../../yosys-config --exec --cxx --cxxflags --ldflags -o my_cmd.so -shared my_cmd.cc --ldlibs
++ ../../yosys-config --exec --cxx --cxxflags -I../.. --ldflags -o my_cmd.so -shared my_cmd.cc --ldlibs
+
+ test0.log: my_cmd.so
+ ../../yosys -Ql test0.log_new -m ./my_cmd.so -p 'my_cmd foo bar' absval_ref.v