summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/0007-Disable-pretty-build.patch4
-rw-r--r--debian/patches/0009-Some-spelling-errors-fixed.patch88
-rw-r--r--debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch6
-rw-r--r--debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch4
-rw-r--r--debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch6
-rw-r--r--debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch6
-rw-r--r--debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch4
-rw-r--r--debian/patches/01_gitrevision.patch14
-rw-r--r--debian/patches/02_removeabc.patch4
-rw-r--r--debian/patches/05_abc_executable.patch4
-rw-r--r--debian/patches/kfreebsd-support.patch24
11 files changed, 41 insertions, 123 deletions
diff --git a/debian/patches/0007-Disable-pretty-build.patch b/debian/patches/0007-Disable-pretty-build.patch
index c115f66b..22e31cbc 100644
--- a/debian/patches/0007-Disable-pretty-build.patch
+++ b/debian/patches/0007-Disable-pretty-build.patch
@@ -7,10 +7,10 @@ Subject: Disable pretty build
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index f357258..13b19ce 100644
+index 383f6a5..0205d18 100644
--- a/Makefile
+++ b/Makefile
-@@ -52,7 +52,7 @@ EXTRA_OBJS =
+@@ -53,7 +53,7 @@ EXTRA_OBJS =
EXTRA_TARGETS =
TARGETS = yosys$(EXE) yosys-config
diff --git a/debian/patches/0009-Some-spelling-errors-fixed.patch b/debian/patches/0009-Some-spelling-errors-fixed.patch
index 40cc827a..a8fb55fd 100644
--- a/debian/patches/0009-Some-spelling-errors-fixed.patch
+++ b/debian/patches/0009-Some-spelling-errors-fixed.patch
@@ -3,83 +3,12 @@ Date: Thu, 12 Jul 2018 13:41:39 +0200
Subject: Some spelling errors fixed
---
- backends/simplec/simplec.cc | 2 +-
- backends/table/table.cc | 2 +-
- backends/verilog/verilog_backend.cc | 2 +-
- frontends/blif/blifparse.cc | 2 +-
- frontends/liberty/liberty.cc | 2 +-
manual/CHAPTER_Overview.tex | 2 +-
manual/command-reference-manual.tex | 2 +-
- passes/cmds/show.cc | 2 +-
- 8 files changed, 8 insertions(+), 8 deletions(-)
+ 2 files changed, 2 insertions(+), 2 deletions(-)
-diff --git a/backends/simplec/simplec.cc b/backends/simplec/simplec.cc
-index 349bc5a..6f2ccbe 100644
---- a/backends/simplec/simplec.cc
-+++ b/backends/simplec/simplec.cc
-@@ -748,7 +748,7 @@ struct SimplecBackend : public Backend {
- log("\n");
- log(" write_simplec [options] [filename]\n");
- log("\n");
-- log("Write simple C code for simulating the design. The C code writen can be used to\n");
-+ log("Write simple C code for simulating the design. The C code written can be used to\n");
- log("simulate the design in a C environment, but the purpose of this command is to\n");
- log("generate code that works well with C-based formal verification.\n");
- log("\n");
-diff --git a/backends/table/table.cc b/backends/table/table.cc
-index 979273d..b75169e 100644
---- a/backends/table/table.cc
-+++ b/backends/table/table.cc
-@@ -109,7 +109,7 @@ struct TableBackend : public Backend {
- else if (cell->output(conn.first))
- *f << "out" << "\t";
- else
-- *f << "unkown" << "\t";
-+ *f << "unknown" << "\t";
-
- *f << log_signal(sigmap(conn.second)) << "\n";
- }
-diff --git a/backends/verilog/verilog_backend.cc b/backends/verilog/verilog_backend.cc
-index ae90315..d53df2e 100644
---- a/backends/verilog/verilog_backend.cc
-+++ b/backends/verilog/verilog_backend.cc
-@@ -1415,7 +1415,7 @@ void dump_module(std::ostream &f, std::string indent, RTLIL::Module *module)
- }
-
- if (!module->processes.empty())
-- log_warning("Module %s contains unmapped RTLIL proccesses. RTLIL processes\n"
-+ log_warning("Module %s contains unmapped RTLIL processes. RTLIL processes\n"
- "can't always be mapped directly to Verilog always blocks. Unintended\n"
- "changes in simulation behavior are possible! Use \"proc\" to convert\n"
- "processes to logic networks and registers.", log_id(module));
-diff --git a/frontends/blif/blifparse.cc b/frontends/blif/blifparse.cc
-index 034b3e7..9116b25 100644
---- a/frontends/blif/blifparse.cc
-+++ b/frontends/blif/blifparse.cc
-@@ -276,7 +276,7 @@ void parse_blif(RTLIL::Design *design, std::istream &f, std::string dff_name, bo
-
- if(lastcell == nullptr || module == nullptr)
- {
-- err_reason = stringf("No primative object to attach .cname %s.", p);
-+ err_reason = stringf("No primitive object to attach .cname %s.", p);
- goto error_with_reason;
- }
-
-diff --git a/frontends/liberty/liberty.cc b/frontends/liberty/liberty.cc
-index 0a5bd84..e90c87a 100644
---- a/frontends/liberty/liberty.cc
-+++ b/frontends/liberty/liberty.cc
-@@ -615,7 +615,7 @@ struct LibertyFrontend : public Frontend {
- LibertyAst *bus_type_node = node->find("bus_type");
-
- if (!bus_type_node || !type_map.count(bus_type_node->value))
-- log_error("Unkown or unsupported type for bus interface %s on cell %s.\n",
-+ log_error("Unknown or unsupported type for bus interface %s on cell %s.\n",
- node->args.at(0).c_str(), log_id(cell_name));
-
- int bus_type_width = std::get<0>(type_map.at(bus_type_node->value));
diff --git a/manual/CHAPTER_Overview.tex b/manual/CHAPTER_Overview.tex
-index 964875d..ae5cf09 100644
+index 2feb0f1..c7d1d5c 100644
--- a/manual/CHAPTER_Overview.tex
+++ b/manual/CHAPTER_Overview.tex
@@ -240,7 +240,7 @@ An RTLIL::Wire object has the following properties:
@@ -104,16 +33,3 @@ index bed6326..eb43467 100644
-signed
mark ports (A, B) that are declared as signed (using the [AB]_SIGNED
-diff --git a/passes/cmds/show.cc b/passes/cmds/show.cc
-index a488732..58acd30 100644
---- a/passes/cmds/show.cc
-+++ b/passes/cmds/show.cc
-@@ -623,7 +623,7 @@ struct ShowPass : public Pass {
- log(" assigned to each unique value of this attribute.\n");
- log("\n");
- log(" -width\n");
-- log(" annotate busses with a label indicating the width of the bus.\n");
-+ log(" annotate buses with a label indicating the width of the bus.\n");
- log("\n");
- log(" -signed\n");
- log(" mark ports (A, B) that are declared as signed (using the [AB]_SIGNED\n");
diff --git a/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch b/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
index 0b46c4a0..5d37598f 100644
--- a/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
+++ b/debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
@@ -7,10 +7,10 @@ Subject: Fix adding of sys.path in yosys-smtbmc
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/backends/smt2/Makefile.inc b/backends/smt2/Makefile.inc
-index dce82f0..f98e610 100644
+index 92941d4..2c0b7c6 100644
--- a/backends/smt2/Makefile.inc
+++ b/backends/smt2/Makefile.inc
-@@ -6,7 +6,7 @@ ifneq ($(CONFIG),emcc)
+@@ -22,7 +22,7 @@ else
TARGETS += yosys-smtbmc
yosys-smtbmc: backends/smt2/smtbmc.py
@@ -18,4 +18,4 @@ index dce82f0..f98e610 100644
+ $(P) sed 's|##yosys-sys-path##|sys.path += ["/usr/share/yosys"]|;' < $< > $@.new
$(Q) chmod +x $@.new
$(Q) mv $@.new $@
-
+ endif
diff --git a/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch b/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
index aa77fe92..33bbedc3 100644
--- a/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
+++ b/debian/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
@@ -11,10 +11,10 @@ Subject: Fix reproducibility of PDF documents in yosys-doc
5 files changed, 21 insertions(+), 8 deletions(-)
diff --git a/Makefile b/Makefile
-index 13b19ce..e7a9de1 100644
+index 0205d18..6f8c067 100644
--- a/Makefile
+++ b/Makefile
-@@ -638,9 +638,9 @@ update-manual: $(TARGETS) $(EXTRA_TARGETS)
+@@ -651,9 +651,9 @@ update-manual: $(TARGETS) $(EXTRA_TARGETS)
cd manual && ../yosys -p 'help -write-tex-command-reference-manual'
manual: $(TARGETS) $(EXTRA_TARGETS)
diff --git a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
index b72651db..af0015d8 100644
--- a/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
+++ b/debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch
@@ -7,10 +7,10 @@ Subject: Do not show g++ build flags in Version string
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
-index e7a9de1..5c381ff 100644
+index 6f8c067..5024349 100644
--- a/Makefile
+++ b/Makefile
-@@ -504,8 +504,7 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
+@@ -514,8 +514,7 @@ libyosys.so: $(filter-out kernel/driver.o,$(OBJS))
$(Q) mkdir -p $(dir $@)
$(P) $(CXX) -o $@ -c $(CPPFLAGS) $(CXXFLAGS) $<
@@ -20,7 +20,7 @@ index e7a9de1..5c381ff 100644
kernel/version_$(GIT_REV).cc: $(YOSYS_SRC)/Makefile
$(P) rm -f kernel/version_*.o kernel/version_*.d kernel/version_*.cc
-@@ -519,8 +518,10 @@ CXXFLAGS_NOVERIFIC = $(CXXFLAGS)
+@@ -529,8 +528,10 @@ CXXFLAGS_NOVERIFIC = $(CXXFLAGS)
LDLIBS_NOVERIFIC = $(LDLIBS)
endif
diff --git a/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch b/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch
index 18ba0e17..fffd15ce 100644
--- a/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch
+++ b/debian/patches/0012-Skip-non-deterministic-test-causing-random-FTBFS-on-.patch
@@ -8,14 +8,14 @@ Subject: Skip non-deterministic test causing random FTBFS on some
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index 5c381ff..b169eb7 100644
+index 5024349..2ed9f0f 100644
--- a/Makefile
+++ b/Makefile
-@@ -566,7 +566,7 @@ test: $(TARGETS) $(EXTRA_TARGETS)
+@@ -576,7 +576,7 @@ test: $(TARGETS) $(EXTRA_TARGETS)
+cd tests/simple && bash run-test.sh $(SEEDOPT)
+cd tests/hana && bash run-test.sh $(SEEDOPT)
+cd tests/asicworld && bash run-test.sh $(SEEDOPT)
-- +cd tests/realmath && bash run-test.sh $(SEEDOPT)
+- # +cd tests/realmath && bash run-test.sh $(SEEDOPT)
+ #+cd tests/realmath && bash run-test.sh $(SEEDOPT)
+cd tests/share && bash run-test.sh $(SEEDOPT)
+cd tests/fsm && bash run-test.sh $(SEEDOPT)
diff --git a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
index 2389eb85..35b623f7 100644
--- a/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
+++ b/debian/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch
@@ -7,10 +7,10 @@ Subject: Let dpkg-buildpackage handle stripping of binaries
1 file changed, 4 deletions(-)
diff --git a/Makefile b/Makefile
-index b169eb7..961e2ce 100644
+index 2ed9f0f..b4aac53 100644
--- a/Makefile
+++ b/Makefile
-@@ -612,19 +612,15 @@ install: $(TARGETS) $(EXTRA_TARGETS)
+@@ -625,19 +625,15 @@ install: $(TARGETS) $(EXTRA_TARGETS)
$(INSTALL_SUDO) mkdir -p $(DESTDIR)$(BINDIR)
$(INSTALL_SUDO) cp $(TARGETS) $(DESTDIR)$(BINDIR)
ifneq ($(filter yosys,$(TARGETS)),)
diff --git a/debian/patches/01_gitrevision.patch b/debian/patches/01_gitrevision.patch
index 8e3b5352..fd31dbbf 100644
--- a/debian/patches/01_gitrevision.patch
+++ b/debian/patches/01_gitrevision.patch
@@ -7,19 +7,21 @@ Subject: Compilation from the upstream code depends on being in the git
Forwarded: doesn't make sense upstream
---
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
-index d759b11..c92c808 100644
+index 8586e97..ea66859 100644
--- a/Makefile
+++ b/Makefile
-@@ -100,7 +100,7 @@ LDLIBS += -lrt
+@@ -101,8 +101,8 @@ LDFLAGS += -rdynamic
+ LDLIBS += -lrt
endif
- YOSYS_VER := 0.8
+-YOSYS_VER := 0.8+$(shell cd $(YOSYS_SRC) && test -e .git && { git log --author=clifford@clifford.at --oneline 4d4665b.. 2> /dev/null | wc -l; })
-GIT_REV := $(shell cd $(YOSYS_SRC) && git rev-parse --short HEAD 2> /dev/null || echo UNKNOWN)
-+GIT_REV := 5706e90
++YOSYS_VER := 0.8+20190328git32bd0f2
++GIT_REV := 32bd0f2
OBJS = kernel/version_$(GIT_REV).o
# set 'ABCREV = default' to use abc/ as it is
diff --git a/debian/patches/02_removeabc.patch b/debian/patches/02_removeabc.patch
index 4ef26c8c..8ef43852 100644
--- a/debian/patches/02_removeabc.patch
+++ b/debian/patches/02_removeabc.patch
@@ -9,10 +9,10 @@ Forwarded: doesn't make sense upstream
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index c92c808..f357258 100644
+index ea66859..383f6a5 100644
--- a/Makefile
+++ b/Makefile
-@@ -350,7 +350,7 @@ LDLIBS += -lpthread
+@@ -356,7 +356,7 @@ LDLIBS += -lpthread
endif
else
ifeq ($(ABCEXTERNAL),)
diff --git a/debian/patches/05_abc_executable.patch b/debian/patches/05_abc_executable.patch
index b4a97529..a59741fc 100644
--- a/debian/patches/05_abc_executable.patch
+++ b/debian/patches/05_abc_executable.patch
@@ -11,10 +11,10 @@ Forwarded: doesn't make sense upstream
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/passes/techmap/abc.cc b/passes/techmap/abc.cc
-index d2d15a4..adc9614 100644
+index 21b70f4..1b36261 100644
--- a/passes/techmap/abc.cc
+++ b/passes/techmap/abc.cc
-@@ -1432,11 +1432,7 @@ struct AbcPass : public Pass {
+@@ -1458,11 +1458,7 @@ struct AbcPass : public Pass {
pi_map.clear();
po_map.clear();
diff --git a/debian/patches/kfreebsd-support.patch b/debian/patches/kfreebsd-support.patch
index d1ae9201..ba4fb8c1 100644
--- a/debian/patches/kfreebsd-support.patch
+++ b/debian/patches/kfreebsd-support.patch
@@ -16,7 +16,7 @@ Subject: Change yosys to look for the #define constant "__unix__" instead of
6 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/kernel/driver.cc b/kernel/driver.cc
-index 1786411..8b328e5 100644
+index a0bb7e6..0ea5505 100644
--- a/kernel/driver.cc
+++ b/kernel/driver.cc
@@ -34,7 +34,7 @@
@@ -28,7 +28,7 @@ index 1786411..8b328e5 100644
# include <sys/resource.h>
# include <sys/types.h>
# include <unistd.h>
-@@ -449,7 +449,7 @@ int main(int argc, char **argv)
+@@ -456,7 +456,7 @@ int main(int argc, char **argv)
if (print_stats)
log_hasher = new SHA1;
@@ -37,7 +37,7 @@ index 1786411..8b328e5 100644
// set stack size to >= 128 MB
{
struct rlimit rl;
-@@ -532,7 +532,7 @@ int main(int argc, char **argv)
+@@ -546,7 +546,7 @@ int main(int argc, char **argv)
#else
std::string meminfo;
std::string stats_divider = ", ";
@@ -46,7 +46,7 @@ index 1786411..8b328e5 100644
std::ifstream statm;
statm.open(stringf("/proc/%lld/statm", (long long)getpid()));
if (statm.is_open()) {
-@@ -599,7 +599,7 @@ int main(int argc, char **argv)
+@@ -613,7 +613,7 @@ int main(int argc, char **argv)
}
}
@@ -56,7 +56,7 @@ index 1786411..8b328e5 100644
{
string filename;
diff --git a/kernel/log.cc b/kernel/log.cc
-index 0ee2170..1dfa89a 100644
+index 400a549..757a49c 100644
--- a/kernel/log.cc
+++ b/kernel/log.cc
@@ -25,7 +25,7 @@
@@ -68,7 +68,7 @@ index 0ee2170..1dfa89a 100644
# include <dlfcn.h>
#endif
-@@ -389,7 +389,7 @@ void log_pop()
+@@ -393,7 +393,7 @@ void log_pop()
log_flush();
}
@@ -77,7 +77,7 @@ index 0ee2170..1dfa89a 100644
void log_backtrace(const char *prefix, int levels)
{
if (levels <= 0) return;
-@@ -584,7 +584,7 @@ void log_wire(RTLIL::Wire *wire, std::string indent)
+@@ -588,7 +588,7 @@ void log_wire(RTLIL::Wire *wire, std::string indent)
// ---------------------------------------------------
// This is the magic behind the code coverage counters
// ---------------------------------------------------
@@ -87,10 +87,10 @@ index 0ee2170..1dfa89a 100644
dict<std::string, std::pair<std::string, int>> extra_coverage_data;
diff --git a/kernel/log.h b/kernel/log.h
-index 0b4905c..0f068a1 100644
+index 7599390..30f2a64 100644
--- a/kernel/log.h
+++ b/kernel/log.h
-@@ -119,7 +119,7 @@ static inline void log_assert_worker(bool cond, const char *expr, const char *fi
+@@ -121,7 +121,7 @@ static inline void log_assert_worker(bool cond, const char *expr, const char *fi
// This is the magic behind the code coverage counters
// ---------------------------------------------------
@@ -100,10 +100,10 @@ index 0b4905c..0f068a1 100644
#define cover(_id) do { \
static CoverData __d __attribute__((section("yosys_cover_list"), aligned(1), used)) = { __FILE__, __FUNCTION__, _id, __LINE__, 0 }; \
diff --git a/kernel/yosys.cc b/kernel/yosys.cc
-index ad03289..822cab9 100644
+index 450e4e4..68ba3e6 100644
--- a/kernel/yosys.cc
+++ b/kernel/yosys.cc
-@@ -77,7 +77,7 @@ std::vector<void*> memhasher_store;
+@@ -79,7 +79,7 @@ std::vector<void*> memhasher_store;
void memhasher_on()
{
@@ -112,7 +112,7 @@ index ad03289..822cab9 100644
memhasher_rng += time(NULL) << 16 ^ getpid();
#endif
memhasher_store.resize(0x10000);
-@@ -660,7 +660,7 @@ struct TclPass : public Pass {
+@@ -679,7 +679,7 @@ struct TclPass : public Pass {
} TclPass;
#endif