summaryrefslogtreecommitdiff
path: root/examples/osu035/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/osu035/Makefile')
-rw-r--r--examples/osu035/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/examples/osu035/Makefile b/examples/osu035/Makefile
new file mode 100644
index 00000000..2bb8162b
--- /dev/null
+++ b/examples/osu035/Makefile
@@ -0,0 +1,13 @@
+
+example.edif: example.ys example.v example.constr osu035_stdcells.lib
+ yosys -l example.yslog -q example.ys
+
+osu035_stdcells.lib:
+ rm -f osu035_stdcells.lib.part osu035_stdcells.lib
+ wget -O osu035_stdcells.lib.part https://vlsiarch.ecen.okstate.edu/flows/MOSIS_SCMOS/latest/cadence/lib/ami035/signalstorm/osu035_stdcells.lib
+ mv osu035_stdcells.lib.part osu035_stdcells.lib
+
+clean:
+ rm -f osu035_stdcells.lib
+ rm -f example.yslog example.edif
+