summaryrefslogtreecommitdiff
path: root/manual/CHAPTER_Prog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'manual/CHAPTER_Prog/Makefile')
-rw-r--r--manual/CHAPTER_Prog/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/manual/CHAPTER_Prog/Makefile b/manual/CHAPTER_Prog/Makefile
new file mode 100644
index 00000000..8e326bdc
--- /dev/null
+++ b/manual/CHAPTER_Prog/Makefile
@@ -0,0 +1,12 @@
+test: stubnets.so
+ yosys -ql test1.log -m ./stubnets.so test.v -p "stubnets"
+ yosys -ql test2.log -m ./stubnets.so test.v -p "opt; stubnets"
+ yosys -ql test3.log -m ./stubnets.so test.v -p "techmap; opt; stubnets -report_bits"
+ tail test1.log test2.log test3.log
+
+stubnets.so: stubnets.cc
+ yosys-config --exec --cxx --cxxflags --ldflags -o $@ -shared $^ --ldlibs
+
+clean:
+ rm -f test1.log test2.log test3.log
+ rm -f stubnets.so stubnets.d