summaryrefslogtreecommitdiff
path: root/manual/FILES_Prog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'manual/FILES_Prog/Makefile')
-rw-r--r--manual/FILES_Prog/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/manual/FILES_Prog/Makefile b/manual/FILES_Prog/Makefile
index d7358188..1afde80f 100644
--- a/manual/FILES_Prog/Makefile
+++ b/manual/FILES_Prog/Makefile
@@ -1,14 +1,13 @@
-
test: stubnets.so
- yosys -q -l test1.log -m ./stubnets.so test.v -p "proc; stubnets"
- yosys -q -l test2.log -m ./stubnets.so test.v -p "proc; opt; stubnets"
- yosys -q -l test3.log -m ./stubnets.so test.v -p "proc; techmap; opt; stubnets -report_bits"
+ yosys -ql test1.log -m ./stubnets.so test.v -p "stubnets"
+ yosys -ql test2.log -m ./stubnets.so test.v -p "opt; stubnets"
+ yosys -ql test3.log -m ./stubnets.so test.v -p "techmap; opt; stubnets -report_bits"
tail test1.log test2.log test3.log
stubnets.so: stubnets.cc
- $(shell yosys-config --cxx --cxxflags --ldflags -o stubnets.so -shared stubnets.cc --ldlibs )
+ $(shell yosys-config --cxx --cxxflags --ldflags -o stubnets.so \
+ -shared stubnets.cc --ldlibs )
clean:
rm -f test1.log test2.log test3.log
rm -f stubnets.so stubnets.d
-