summaryrefslogtreecommitdiff
path: root/passes
diff options
context:
space:
mode:
Diffstat (limited to 'passes')
-rw-r--r--passes/techmap/Makefile.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/passes/techmap/Makefile.inc b/passes/techmap/Makefile.inc
index ba365525..2e90215e 100644
--- a/passes/techmap/Makefile.inc
+++ b/passes/techmap/Makefile.inc
@@ -3,8 +3,10 @@ GENFILES += passes/techmap/stdcells.inc
OBJS += passes/techmap/techmap.o
passes/techmap/stdcells.inc: techlibs/stdcells.v
+ echo -n "// autogenerated from $< on " > $@.new
+ LANG=C date >> $@.new
od -v -td1 -w1 $< | awk 'BEGIN { print "static char stdcells_code[] = {"; } $$2 != "" { print $$2 ","; } \
- END { print 0 "};"; }' | fmt > $@.new
+ END { print 0 "};"; }' | fmt >> $@.new
mv $@.new $@
passes/techmap/techmap.o: passes/techmap/stdcells.inc