summaryrefslogtreecommitdiff
path: root/techlibs
diff options
context:
space:
mode:
Diffstat (limited to 'techlibs')
-rw-r--r--techlibs/Makefile.inc7
-rw-r--r--techlibs/common/Makefile.inc7
-rw-r--r--techlibs/common/blackbox.sed (renamed from techlibs/blackbox.sed)0
-rw-r--r--techlibs/common/simlib.v (renamed from techlibs/simlib.v)0
-rw-r--r--techlibs/common/stdcells.v (renamed from techlibs/stdcells.v)0
-rw-r--r--techlibs/common/stdcells_sim.v (renamed from techlibs/stdcells_sim.v)0
6 files changed, 7 insertions, 7 deletions
diff --git a/techlibs/Makefile.inc b/techlibs/Makefile.inc
deleted file mode 100644
index 6c2a5f66..00000000
--- a/techlibs/Makefile.inc
+++ /dev/null
@@ -1,7 +0,0 @@
-
-EXTRA_TARGETS += techlibs/blackbox.v
-
-techlibs/blackbox.v: techlibs/blackbox.sed techlibs/simlib.v techlibs/stdcells_sim.v
- cat techlibs/simlib.v techlibs/stdcells_sim.v | sed -rf techlibs/blackbox.sed > techlibs/blackbox.v.new
- mv techlibs/blackbox.v.new techlibs/blackbox.v
-
diff --git a/techlibs/common/Makefile.inc b/techlibs/common/Makefile.inc
new file mode 100644
index 00000000..ad007645
--- /dev/null
+++ b/techlibs/common/Makefile.inc
@@ -0,0 +1,7 @@
+
+EXTRA_TARGETS += techlibs/common/blackbox.v
+
+techlibs/common/blackbox.v: techlibs/common/blackbox.sed techlibs/common/simlib.v techlibs/common/stdcells_sim.v
+ cat techlibs/common/simlib.v techlibs/common/stdcells_sim.v | sed -rf techlibs/common/blackbox.sed > techlibs/common/blackbox.v.new
+ mv techlibs/common/blackbox.v.new techlibs/common/blackbox.v
+
diff --git a/techlibs/blackbox.sed b/techlibs/common/blackbox.sed
index 4e9a3a7c..4e9a3a7c 100644
--- a/techlibs/blackbox.sed
+++ b/techlibs/common/blackbox.sed
diff --git a/techlibs/simlib.v b/techlibs/common/simlib.v
index 7cd9906c..7cd9906c 100644
--- a/techlibs/simlib.v
+++ b/techlibs/common/simlib.v
diff --git a/techlibs/stdcells.v b/techlibs/common/stdcells.v
index d861d796..d861d796 100644
--- a/techlibs/stdcells.v
+++ b/techlibs/common/stdcells.v
diff --git a/techlibs/stdcells_sim.v b/techlibs/common/stdcells_sim.v
index 6e5d2719..6e5d2719 100644
--- a/techlibs/stdcells_sim.v
+++ b/techlibs/common/stdcells_sim.v