summaryrefslogtreecommitdiff
path: root/tests/hana/run-test.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tests/hana/run-test.sh')
-rwxr-xr-xtests/hana/run-test.sh14
1 files changed, 13 insertions, 1 deletions
diff --git a/tests/hana/run-test.sh b/tests/hana/run-test.sh
index fb766eec..878c80b3 100755
--- a/tests/hana/run-test.sh
+++ b/tests/hana/run-test.sh
@@ -1,2 +1,14 @@
#!/bin/bash
-exec ${MAKE:-make} -f ../tools/autotest.mk EXTRA_FLAGS="-l hana_vlib.v -n 300 -e" test_*.v
+
+OPTIND=1
+seed="" # default to no seed specified
+while getopts "S:" opt
+do
+ case "$opt" in
+ S) arg="${OPTARG#"${OPTARG%%[![:space:]]*}"}" # remove leading space
+ seed="SEED=$arg" ;;
+ esac
+done
+shift "$((OPTIND-1))"
+
+exec ${MAKE:-make} -f ../tools/autotest.mk $seed EXTRA_FLAGS="-l hana_vlib.v -n 300 -e" test_*.v