summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules4
2 files changed, 6 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 5eb699a..b261f42 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,10 @@ Homepage: https://github.com/FruitieX/znc-backlog
Package: znc-backlog
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${znc:Depends}
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ znc (>= ${znc:Version}),
+ znc (<< ${znc:Version}.~)
Enhances: znc
Description: module for requesting backlog from znc bouncer
znc-backlog is a ZNC module that makes it easy to request backlog. Its
diff --git a/debian/rules b/debian/rules
index 254b997..8eeedb6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
# output every command that modifies files on the build system.
#export DH_VERBOSE = 1
-ZNC_VERSION=$(shell dpkg-query -f '$${Version}' -W znc-dev)
+ZNC_VERSION=$(shell dpkg-query -f '$${source:Version}' -W znc-dev)
# see FEATURE AREAS in dpkg-buildflags(1)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
@@ -14,5 +14,5 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
dh $@
override_dh_gencontrol:
- dh_gencontrol -- "-Vznc:Depends=znc (=$(ZNC_VERSION))"
+ dh_gencontrol -- "-Vznc:Version=$(ZNC_VERSION)"