summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/control27
-rw-r--r--debian/copyright28
-rw-r--r--debian/docs1
-rw-r--r--debian/gbp.conf9
-rw-r--r--debian/install1
-rw-r--r--debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch18
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules18
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch8
11 files changed, 117 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3ded31d
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+znc-backlog (0.20170713-1) unstable; urgency=medium
+
+ * Initial release. Closes: #907180
+
+ -- Felipe Sateler <fsateler@debian.org> Tue, 11 Sep 2018 18:13:27 -0300
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..d21ff3d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,27 @@
+Source: znc-backlog
+Section: net
+Priority: optional
+Maintainer: Felipe Sateler <fsateler@debian.org>
+Build-Depends: debhelper-compat (= 11),
+ znc-dev
+Standards-Version: 4.2.1
+Homepage: https://github.com/FruitieX/znc-backlog
+Vcs-Git: https://salsa.debian.org/fsateler/znc-backlog.git
+Vcs-Browser: https://salsa.debian.org/fsateler/znc-backlog
+
+Package: znc-backlog
+Architecture: any
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ znc (>= ${znc:Version}),
+ znc (<< ${znc:Version}.~)
+Enhances: znc
+Description: module for requesting backlog from znc bouncer
+ znc-backlog is a ZNC module that makes it easy to request backlog. Its
+ intended use is for when you have just launched your IRC client and gotten
+ a few lines of backlog sent to you, but want to read more. Instead of
+ having to deal with shelling into the box where you run ZNC and manually
+ sifting through the logs, you can issue a short command in your IRC
+ client to request any amount of the most recent lines of log.
+ .
+ For more information about ZNC, see the znc package.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..19278e7
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,28 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: znc-backlog
+Source: https://github.com/FruitieX/znc-backlog
+
+Files: *
+Copyright: 2013-2017 Rasmus Eskola
+License: Apache-2.0
+
+Files: debian/*
+Copyright: 2017 Felipe Sateler <fsateler@debian.org>
+License: Apache-2.0
+
+License: Apache-2.0
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+ .
+ https://www.apache.org/licenses/LICENSE-2.0
+ .
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+ .
+ On Debian systems, the complete text of the Apache version 2.0 license
+ can be found in "/usr/share/common-licenses/Apache-2.0".
+
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..b43bf86
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..fab3101
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,9 @@
+[DEFAULT]
+pristine-tar = True
+patch-numbers = False
+debian-branch = debian/unstable
+upstream-branch = upstream/latest
+
+[dch]
+full = True
+multimaint-merge = True
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..f6a3f83
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+backlog.so usr/lib/znc/
diff --git a/debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch b/debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch
new file mode 100644
index 0000000..b8f5fe8
--- /dev/null
+++ b/debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch
@@ -0,0 +1,18 @@
+From: Felipe Sateler <fsateler@debian.org>
+Date: Fri, 8 Dec 2017 12:01:19 -0300
+Subject: Don't fail to clean if not built yet
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 2f8df2f..7e93c2f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,4 +2,4 @@ backlog: backlog.cpp
+ znc-buildmod backlog.cpp
+
+ clean:
+- rm *.so
++ rm -f *.so
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..00af91d
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+Don-t-fail-to-clean-if-not-built-yet.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8eeedb6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+ZNC_VERSION=$(shell dpkg-query -f '$${source:Version}' -W znc-dev)
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@
+
+override_dh_gencontrol:
+ dh_gencontrol -- "-Vznc:Version=$(ZNC_VERSION)"
+
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..de8e4d5
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,8 @@
+# Compulsory line, this is a version 4 file
+version=4
+
+# GitHub hosted projects
+opts="filenamemangle=s%(?:.*?)?v?(\d[\d.]*)\.tar\.gz%<project>-$1.tar.gz%" \
+ https://github.com/FruitieX/znc-backlog/tags \
+ (?:.*?/)?v?(\d[\d.]*)\.tar\.gz debian uupdate
+