summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--debian/compat1
-rw-r--r--debian/control11
-rw-r--r--debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch18
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
6 files changed, 21 insertions, 26 deletions
diff --git a/debian/changelog b/debian/changelog
index 3ded31d..341cda4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+znc-backlog (0.20180824-1) unstable; urgency=medium
+
+ * New upstream snapshot
+ - Drop patches applied upstream
+ * Relax dependency on znc.
+ Allow binNMU version to change, but not actual NMUs (since those
+ might change the ABI). (Closes: #916764)
+ * Document location of debian packaging repository
+ * Bump debhelper compat level to 11
+
+ -- Felipe Sateler <fsateler@debian.org> Sun, 23 Dec 2018 14:26:18 -0300
+
znc-backlog (0.20170713-1) unstable; urgency=medium
* Initial release. Closes: #907180
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index 5eb699a..d21ff3d 100644
--- a/debian/control
+++ b/debian/control
@@ -2,16 +2,19 @@ Source: znc-backlog
Section: net
Priority: optional
Maintainer: Felipe Sateler <fsateler@debian.org>
-Build-Depends: debhelper (>= 10),
+Build-Depends: debhelper-compat (= 11),
znc-dev
Standards-Version: 4.2.1
Homepage: https://github.com/FruitieX/znc-backlog
-#Vcs-Git: https://anonscm.debian.org/collab-maint/znc-backlog.git
-#Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/znc-backlog.git
+Vcs-Git: https://salsa.debian.org/fsateler/znc-backlog.git
+Vcs-Browser: https://salsa.debian.org/fsateler/znc-backlog
Package: znc-backlog
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${znc:Depends}
+Depends: ${shlibs:Depends},
+ ${misc:Depends},
+ znc (>= ${znc:Version}),
+ znc (<< ${znc:Version}.~)
Enhances: znc
Description: module for requesting backlog from znc bouncer
znc-backlog is a ZNC module that makes it easy to request backlog. Its
diff --git a/debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch b/debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch
deleted file mode 100644
index b8f5fe8..0000000
--- a/debian/patches/Don-t-fail-to-clean-if-not-built-yet.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From: Felipe Sateler <fsateler@debian.org>
-Date: Fri, 8 Dec 2017 12:01:19 -0300
-Subject: Don't fail to clean if not built yet
-
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 2f8df2f..7e93c2f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -2,4 +2,4 @@ backlog: backlog.cpp
- znc-buildmod backlog.cpp
-
- clean:
-- rm *.so
-+ rm -f *.so
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 00af91d..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-Don-t-fail-to-clean-if-not-built-yet.patch
diff --git a/debian/rules b/debian/rules
index 254b997..8eeedb6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
# output every command that modifies files on the build system.
#export DH_VERBOSE = 1
-ZNC_VERSION=$(shell dpkg-query -f '$${Version}' -W znc-dev)
+ZNC_VERSION=$(shell dpkg-query -f '$${source:Version}' -W znc-dev)
# see FEATURE AREAS in dpkg-buildflags(1)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
@@ -14,5 +14,5 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
dh $@
override_dh_gencontrol:
- dh_gencontrol -- "-Vznc:Depends=znc (=$(ZNC_VERSION))"
+ dh_gencontrol -- "-Vznc:Version=$(ZNC_VERSION)"