summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÉtienne Mollier <emollier@debian.org>2024-01-19 18:33:09 +0100
committerÉtienne Mollier <emollier@debian.org>2024-01-19 18:33:09 +0100
commitfd413fd70fb9d5b3f9869d4212349470c1575eac (patch)
tree22293bcfe54f08c2cf8a8e605e0ed2ecea922d0d
parent7f99ff25c4539caaca77f4a2dcf0cace23e71247 (diff)
respect the CPU baseline.
Forwarded: not-needed Last-Update: 2022-07-09 FIXME: implement multiple executables using SIMDe as distributed by Debian. Last-Update: 2022-07-09 Gbp-Pq: Name baseline.patch
-rw-r--r--CMakeLists.txt2
-rw-r--r--Makefile16
-rw-r--r--setup.py2
3 files changed, 2 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b570fae..be60a77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=native") # SIMD
+#set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=native") # SIMD
# build abPOA as a static library by default
set(BUILD_SHARED_LIBS OFF CACHE BOOL "Build all libraries as shared")
diff --git a/Makefile b/Makefile
index 430b51e..df2a40f 100644
--- a/Makefile
+++ b/Makefile
@@ -39,9 +39,6 @@ SRC_DIR = ./src
# This is everything that gets bundled into our main library
OBJS = $(addprefix $(SRC_DIR)/, abpoa_align.o abpoa_graph.o abpoa_plot.o abpoa_seed.o abpoa_seq.o abpoa_output.o kalloc.o kstring.o simd_abpoa_align.o simd_check.o utils.o)
-# Set default SIMD flags
-SIMD_FLAG = -march=native
-
# auto-detect some appropriate defaults -- this helps users in the common case of macOS with arm
ifeq ($(ARCH), $(filter $(ARCH), aarch64 arm64))
ifeq ($(OS), Darwin)
@@ -52,19 +49,6 @@ else
endif
endif
-# override if user specified
-ifneq ($(armv7),) # for ARMv7
- SIMD_FLAG = -march=armv7-a -mfpu=neon -D__AVX2__
-else
-ifneq ($(armv8),) # for ARMv8
-ifneq ($(aarch64),) # for Aarch64
- SIMD_FLAG = -march=armv8-a+simd -D__AVX2__
-else # for Aarch32
- SIMD_FLAG = -march=armv8-a+simd -mfpu=auto -D__AVX2__
-endif
-endif
-endif
-
# some more possible overrides
FLAG_SSE2 = -msse2
FLAG_SSE41 = -msse4.1
diff --git a/setup.py b/setup.py
index 52c0e7e..f03fcfb 100644
--- a/setup.py
+++ b/setup.py
@@ -76,6 +76,6 @@ setup(
depends=[module_dep] + [src_dir + x for x in depends],
libraries=['z', 'm', 'pthread'],
# extra_compile_args=['-O3', '-Wno-error=declaration-after-statement', '-D __DEBUG__'] + simde + simd_flag
- extra_compile_args=['-O3', '-Wno-misleading-indentation', '-Wno-error=declaration-after-statement'] + simde + simd_flag
+ extra_compile_args=['-O3', '-Wno-misleading-indentation', '-Wno-error=declaration-after-statement'] + simde
)]
)