summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2022-07-20 16:11:30 +0200
committerAndrej Shadura <andrewsh@debian.org>2022-07-20 21:00:23 +0200
commit4e74fb2138f130d4ee768297babdaa2a5bade9b8 (patch)
tree6cdfacd5eade3f73a9da80baa77a1253ebb585f6
parentaa20248aba3a248dc8e638ffe918d790e7b8b6f4 (diff)
Replace -Wno-c++11-narrowing with -Wno-narrowing
Gbp-Pq: Name remove-unconditional-Wno-c++11-narrowing.patch
-rw-r--r--configure.ac2
-rw-r--r--src/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0c0d13a..c8bebf0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,7 +150,7 @@ AS_IF([test x$enable_compiler_flags != xno], [
CFLAGS="$CFLAGS -Wall -Wextra -Wno-unused-parameter -std=gnu99 -pipe -g"
CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wno-unused-parameter -fno-strict-aliasing -pipe -g"
AC_CXX_FLAG([-std=c++11])
- AC_CXX_FLAG([-Wno-c++11-narrowing])
+ AC_CXX_FLAG([-Wno-narrowing])
AC_C_FLAG([-Wno-unused-local-typedefs])
AC_CXX_FLAG([-Wno-unused-local-typedefs])
diff --git a/src/Makefile b/src/Makefile
index 6252392..a1c3ba8 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -190,7 +190,7 @@ $(d)auto4_base.o_FLAGS := $(CFLAGS_FREETYPE)
$(d)charset_detect.o_FLAGS := -D_X86_
$(d)font_file_lister_fontconfig.o_FLAGS := $(CFLAGS_FONTCONFIG)
$(d)subtitles_provider.o_FLAGS := $(CFLAGS_LIBASS)
-$(d)subtitles_provider_libass.o_FLAGS := $(CFLAGS_LIBASS) -Wno-c++11-narrowing
+$(d)subtitles_provider_libass.o_FLAGS := $(CFLAGS_LIBASS) -Wno-narrowing
$(d)text_file_reader.o_FLAGS := -D_X86_
$(d)video_provider_manager.o_FLAGS := $(CFLAGS_FFMS2)
$(d)auto4_lua.o_FLAGS := `pkg-config --silence-errors --cflags luajit` `pkg-config --silence-errors --cflags lua51`