summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwangqr <wangqr@wangqr.tk>2020-02-17 14:42:07 +0800
committerAndrej Shadura <andrewsh@debian.org>2022-07-20 16:13:45 +0200
commitdafc7dd57fb675a98fc02e4ad074e2fa7ad14a36 (patch)
tree84efe31bb4ce102faef13bc8ffb143537b6e21e3
parent23052682015b681de6408a2feee64d80a7944754 (diff)
[PATCH] Use target name without directory in $*_OBJ macro
Fix Aegisub/Aegisub#171 Gbp-Pq: Name make-4.3.patch
-rw-r--r--Makefile.target2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.target b/Makefile.target
index d3b6e15..b83fcf3 100644
--- a/Makefile.target
+++ b/Makefile.target
@@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
# Libraries contain all object files they depend on (but they may depend on other files)
# Not using libtool on OS X because it has an unsilenceable warning about a
# compatibility issue with BSD 4.3 (wtf)
-lib%.a: $$($$*_OBJ)
+lib%.a: $$($$(*F)_OBJ)
@$(BIN_MKDIR_P) $(dir $@)
$(BIN_AR) cru $@ $(filter %.o,$^)
$(BIN_RANLIB) $@