summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml15
1 files changed, 6 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index b42cab6..3120baf 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,5 @@
language: python
-dist: trusty
python:
-- 3.4
- 3.5
- 3.6
@@ -13,9 +11,8 @@ before_install:
install:
- pip install --upgrade pip setuptools wheel
-# aiohttp git repo has only *.pyx files, so install cython too.
-- '[ -z "$MASTER_AIOHTTP" ] || pip install -U cython git+https://github.com/KeepSafe/aiohttp.git'
- pip install -Ur requirements-dev.txt
+- pip install codecov
before_script:
# Start X-server for Selenium tests.
@@ -25,7 +22,10 @@ before_script:
script:
- '[ "$TYPE" != "test" ] || python setup.py test --addopts -v --addopts -s'
-- '[ "$TYPE" != "lint" ] || python setup.py check'
+- '[ "$TYPE" != "lint" ] || python setup.py check -rms'
+
+after_success:
+ codecov
env:
global:
@@ -33,10 +33,7 @@ env:
matrix:
# PYTHONASYNCIODEBUG environment variable is considered as enabled if it
# is any non empty string.
- - TYPE=test PYTHONASYNCIODEBUG= MASTER_AIOHTTP=
- - TYPE=test PYTHONASYNCIODEBUG=x MASTER_AIOHTTP=
- - TYPE=test PYTHONASYNCIODEBUG= MASTER_AIOHTTP=x
- - TYPE=test PYTHONASYNCIODEBUG=x MASTER_AIOHTTP=x
+ - TYPE=test
matrix:
include: