summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <dimitri.ledkov@canonical.com>2014-05-17 02:40:04 +0100
committerDimitri John Ledkov <dimitri.ledkov@canonical.com>2014-05-17 02:54:39 +0100
commitaa8ab5be30d1072509f430383ac5ded76bb5c35c (patch)
tree320743ba2c1d5eddb2e7cd7aa47483f78dbe5584
parent24e727dbe9924f9ba6e8e908435e8d86944801f2 (diff)
* Fix FTBFS with gnutls28. (Closes: #624089)HEADdebian/4.1.1+dfsg1-3.2master
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/50_fix_ftbfs_gnutls_3.dpatch24
3 files changed, 32 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4f4af22..b192e1a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+anubis (4.1.1+dfsg1-3.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Fix FTBFS with gnutls28. (Closes: #624089)
+
+ -- Dimitri John Ledkov <xnox@ubuntu.com> Sat, 17 May 2014 02:39:51 +0100
+
anubis (4.1.1+dfsg1-3.1) unstable; urgency=low
* Non-maintainer upload.
diff --git a/debian/patches/00list b/debian/patches/00list
index 460cdb7..52ddd50 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -2,3 +2,4 @@
20_pkg-config-for-gnutls
30_guile-include-setjmp
40_binutils-gold.dpatch
+50_fix_ftbfs_gnutls_3.dpatch
diff --git a/debian/patches/50_fix_ftbfs_gnutls_3.dpatch b/debian/patches/50_fix_ftbfs_gnutls_3.dpatch
new file mode 100644
index 0000000..052d469
--- /dev/null
+++ b/debian/patches/50_fix_ftbfs_gnutls_3.dpatch
@@ -0,0 +1,24 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 50_fix_ftbfs_gnutls_3.dpatch by Dimitri John Ledkov <xnox@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Fix FTBFS with gnutls 3
+
+@DPATCH@
+diff --git a/src/tls.c b/src/tls.c
+index 42cb66d..48abdef 100644
+--- a/src/tls.c
++++ b/src/tls.c
+@@ -294,7 +294,11 @@ start_ssl_server (NET_STREAM sd_client, const char *cafile, const char *cert,
+ static void
+ verify_certificate (gnutls_session session)
+ {
+- int status = gnutls_certificate_verify_peers (session);
++ int status=0;
++ if (gnutls_certificate_verify_peers2 (session, &status) < 0)
++ {
++ return;
++ }
+
+ if (status == GNUTLS_E_NO_CERTIFICATE_FOUND)
+ {