summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Hartge <sven@svenhartge.de>2021-02-03 07:44:20 +0100
committerSven Hartge <sven@svenhartge.de>2021-02-03 07:44:20 +0100
commitd5ed149340e04260d492cfc2671ab364ad54af6e (patch)
tree3be86f9db4523cb74c8183467cac52ebf21723af
parent938d46f6784e1d516204f6d6bec49fc7f643cfd5 (diff)
parentd3a28f4cf0e29e4d4c058ca39cacc6f57b9e36fd (diff)
Merge tag 'debian/9.6.7-3' into buster-backportsdebian/9.6.7-3_bpo10+1
bacula release 9.6.7-3 for unstable (sid) (maintainer view tag generated by dgit --quilt=gbp)
-rw-r--r--debian/changelog15
-rw-r--r--debian/control2
-rw-r--r--debian/patches/series3
-rw-r--r--debian/patches/upstream/fix-memory-overflow-access20
4 files changed, 36 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 87a522c2..1d80127a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,19 @@
-bacula (9.6.7-2~bpo10+1) buster-backports; urgency=medium
+bacula (9.6.7-3~bpo10+1) buster-backports; urgency=medium
* Rebuild for buster-backports.
- -- Sven Hartge <sven@svenhartge.de> Mon, 25 Jan 2021 09:55:57 +0100
+ -- Sven Hartge <sven@svenhartge.de> Wed, 03 Feb 2021 07:44:13 +0100
+
+bacula (9.6.7-3) unstable; urgency=medium
+
+ [ Carsten Leonhardt ]
+ * Update Standards-Version to 4.5.1, no changes required.
+
+ [ Sven Hartge ]
+ * Add upstream patch fixing a memory overflow access
+ * Reorder patches in series to apply upstream patches first
+
+ -- Carsten Leonhardt <leo@debian.org> Sun, 31 Jan 2021 19:27:24 +0100
bacula (9.6.7-2) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 34c44af2..cdd5106f 100644
--- a/debian/control
+++ b/debian/control
@@ -25,7 +25,7 @@ Build-Depends: autoconf,
postgresql-server-dev-all,
qtbase5-dev,
zlib1g-dev
-Standards-Version: 4.5.0
+Standards-Version: 4.5.1
Rules-Requires-Root: no
Vcs-Browser: https://salsa.debian.org/bacula-team/bacula
Vcs-Git: https://salsa.debian.org/bacula-team/bacula.git
diff --git a/debian/patches/series b/debian/patches/series
index 10f5ff78..16c934a2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,6 +3,8 @@ upstream/relative-dirs-for-reproduceability
upstream/fix-pkg-config-autoconf-macro
upstream/fix-8bit-encoding
upstream/fix-make_db-scripts_easier_to_use
+upstream/fix-memory-overflow-access
+upstream/btraceback-verbose
debian/fix-default-config
debian/fix-default-dbtype
debian/fix-sql-bindir
@@ -20,5 +22,4 @@ debian/fix-desktop-in-files
debian/non-silent-build
#debian/fix-baculabackupreport-defaults
debian/fix-usr_libexec_paths
-upstream/btraceback-verbose
debian/fix-mysql-racecondition
diff --git a/debian/patches/upstream/fix-memory-overflow-access b/debian/patches/upstream/fix-memory-overflow-access
new file mode 100644
index 00000000..cf3f8fd2
--- /dev/null
+++ b/debian/patches/upstream/fix-memory-overflow-access
@@ -0,0 +1,20 @@
+Description: alist: Fix for memory overflow access.
+Author: Radosław Korzeniewski <radekk@inteos.pl>
+Last-Update: 2020-12-24
+Forwarded: not-needed
+
+Upstream commit 5ce0d3ff70d34dd05bb303d3d696f31c1785960c
+
+diff --git a/src/lib/alist.c b/src/lib/alist.c
+index 30914152c..81f60aba7 100644
+--- a/src/lib/alist.c
++++ b/src/lib/alist.c
+@@ -183,7 +183,7 @@ void * baselist::remove_item(int index)
+ /* Get the index item -- we should probably allow real indexing here */
+ void * baselist::get(int index)
+ {
+- if (items == NULL || index < 0 || index > last_item) {
++ if (items == NULL || index < 0 || index >= last_item) {
+ return NULL;
+ }
+ return items[index];