summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominique Belhachemi <domibel@debian.org>2021-11-06 19:31:45 +0100
committerÉtienne Mollier <emollier@debian.org>2021-11-06 19:31:45 +0100
commit05c8f38a0771293af2f847f3ffe69c287c427b7c (patch)
treef324297ef7a2e41e944d30e655e08fcee12a9f3f
parent6f829f69306260757ec25f8a33672be96db4f6b0 (diff)
run simple test after compilation
The test suite can be extended once we add some small and simple bam files. Gbp-Pq: Name 0008_Cmake_Test.patch
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2b96c3..7c60888 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,8 @@ cmake_policy( SET CMP0048 NEW )
# set project name and version
project( BamTools LANGUAGES CXX VERSION 2.5.1 )
+enable_testing()
+
# on macOS, MACOSX_RPATH is enabled by default on more recent versions
# of CMake. Disable this behaviour, and let user enable it if need be.
cmake_policy( SET CMP0042 OLD )
@@ -97,3 +99,11 @@ include_directories( src )
# list subdirectories to build in
add_subdirectory( src )
+
+add_test(NAME bamtools_help
+ COMMAND bin/bamtools --help
+)
+
+add_test(NAME bamtools_stats
+ COMMAND bin/bamtools stats -in ${CMAKE_BINARY_DIR}/../debian/sam_spec_example.bam
+)