summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control1
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/typo.patch17
-rwxr-xr-xdebian/rules4
-rw-r--r--src/toolkit/bamtools_filter.cpp2
6 files changed, 32 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 62b2276..7660047 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+bamtools (2.5.2+dfsg-5) unstable; urgency=medium
+
+ * d/control: add myself to uploaders.
+ * d/rules: preserve pristine Doxyfile. (Closes: #1043881)
+ * typo.patch: new: fix typo caught by lintian.
+
+ -- Étienne Mollier <emollier@debian.org> Fri, 15 Dec 2023 19:09:45 +0100
+
bamtools (2.5.2+dfsg-4) unstable; urgency=medium
* Team upload.
diff --git a/debian/control b/debian/control
index 1f28ce1..c9edd85 100644
--- a/debian/control
+++ b/debian/control
@@ -3,6 +3,7 @@ Maintainer: Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.
Uploaders: Michael R. Crusoe <crusoe@debian.org>,
Andreas Tille <tille@debian.org>,
Kevin Murray <spam@kdmurray.id.au>,
+ Étienne Mollier <emollier@debian.org>
Section: science
Priority: optional
Build-Depends: debhelper-compat (= 13),
diff --git a/debian/patches/series b/debian/patches/series
index b318add..604cc9e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
0001-ignore-thirdparty-and-fix-jsoncpp.patch
shared_and_static.patch
#fix_soversion.patch
+typo.patch
diff --git a/debian/patches/typo.patch b/debian/patches/typo.patch
new file mode 100644
index 0000000..fdb5b4d
--- /dev/null
+++ b/debian/patches/typo.patch
@@ -0,0 +1,17 @@
+Description: fix typo caught by lintian.
+Author: Étienne Mollier <emollier@debian.org>
+Forwarded: https://github.com/pezmaster31/bamtools/pull/231
+Last-Update: 2023-12-15
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- bamtools.orig/src/toolkit/bamtools_filter.cpp
++++ bamtools/src/toolkit/bamtools_filter.cpp
+@@ -1020,7 +1020,7 @@
+ const std::string isFirstMateDesc = "keep only alignments marked as first mate?";
+ const std::string isMappedDesc = "keep only alignments that were mapped?";
+ const std::string isMateMappedDesc = "keep only alignments with mates that mapped";
+- const std::string isMateReverseDesc = "keep only alignments with mate on reverese strand?";
++ const std::string isMateReverseDesc = "keep only alignments with mate on reverse strand?";
+ const std::string isPairedDesc = "keep only alignments that were sequenced as paired?";
+ const std::string isPrimaryDesc = "keep only alignments marked as primary?";
+ const std::string isProperPairDesc = "keep only alignments that passed PE resolution?";
diff --git a/debian/rules b/debian/rules
index 61fa368..3fd09d4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,6 +18,7 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
endif
override_dh_auto_build-indep:
+ cp docs/Doxyfile docs/Doxyfile.orig
doxygen -u docs/Doxyfile
doxygen docs/Doxyfile
@@ -40,3 +41,6 @@ override_dh_install-indep:
describe-current-version:
git describe --tags upstream | sed 's,^release-,,;s,-,+,;s,-,~,;'
+
+execute_after_dh_auto_clean:
+ test ! -f docs/Doxyfile.orig || mv docs/Doxyfile.orig docs/Doxyfile
diff --git a/src/toolkit/bamtools_filter.cpp b/src/toolkit/bamtools_filter.cpp
index 81df0b9..69824cc 100644
--- a/src/toolkit/bamtools_filter.cpp
+++ b/src/toolkit/bamtools_filter.cpp
@@ -1020,7 +1020,7 @@ FilterTool::FilterTool()
const std::string isFirstMateDesc = "keep only alignments marked as first mate?";
const std::string isMappedDesc = "keep only alignments that were mapped?";
const std::string isMateMappedDesc = "keep only alignments with mates that mapped";
- const std::string isMateReverseDesc = "keep only alignments with mate on reverese strand?";
+ const std::string isMateReverseDesc = "keep only alignments with mate on reverse strand?";
const std::string isPairedDesc = "keep only alignments that were sequenced as paired?";
const std::string isPrimaryDesc = "keep only alignments marked as primary?";
const std::string isProperPairDesc = "keep only alignments that passed PE resolution?";