summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-23 18:13:05 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-23 18:13:05 +0000
commite8515be07c35dc99904b40c429e3391d10f0155a (patch)
tree235e8f1d5e61a2e599fe73f00cf3c9c5c710b133
parentd890ea58f5978337223229ff054cbdd9af187cba (diff)
Portability fix: Fix on libcs where st_mtime is not a macro (ie, ones lacking st_mtim.)debian/5.0.2archive/debian/5.0.2
-rw-r--r--cprogs/cgi-fcgi-interp.c4
-rw-r--r--debian/changelog7
2 files changed, 9 insertions, 2 deletions
diff --git a/cprogs/cgi-fcgi-interp.c b/cprogs/cgi-fcgi-interp.c
index 7aef026..63db94b 100644
--- a/cprogs/cgi-fcgi-interp.c
+++ b/cprogs/cgi-fcgi-interp.c
@@ -441,12 +441,12 @@ static bool stab_isnewer(const struct stat *a, const struct stat *b) {
fprintf(stderr,"stab_isnewer mtime %lu %lu\n",
(unsigned long)a->st_mtime,
(unsigned long)b->st_mtime);
- return a->st_mtime > &b->st_mtime;
+ return a->st_mtime > b->st_mtime;
}
static void stab_mtimenow(struct stat *out) {
out->st_mtime = time(NULL);
- if (baseline_time.st_mtime == (time_t)-1) diee("(stage2) time()");
+ if (out->st_mtime == (time_t)-1) diee("(stage2) time()");
if (debugmode)
fprintf(stderr,"stab_mtimenow mtime %lu\n",
(unsigned long)out->st_mtime);
diff --git a/debian/changelog b/debian/changelog
index 78dd0be..17463aa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+chiark-utils (5.0.2) unstable; urgency=medium
+
+ * Portability fix: Fix on libcs where st_mtime is not a macro
+ (ie, ones lacking st_mtim.)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 23 Jan 2017 18:12:52 +0000
+
chiark-utils (5.0.1) unstable; urgency=medium
* with-lock-ex: provide -l