summaryrefslogtreecommitdiff
path: root/examples/sqlite3/init-func/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sqlite3/init-func/Makefile')
-rw-r--r--examples/sqlite3/init-func/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/sqlite3/init-func/Makefile b/examples/sqlite3/init-func/Makefile
new file mode 100644
index 0000000..d771bdc
--- /dev/null
+++ b/examples/sqlite3/init-func/Makefile
@@ -0,0 +1,21 @@
+#!/usr/bin/make
+##########################################################################
+# FILE IDENTIFICATION
+#
+# Name: Makefile
+# Purpose: Makefile for SQLite 3 init function example.
+# Programer: Aurelio Bignoli
+# Date Started: Oct 2004
+#
+# This file, part of CLSQL, is Copyright (c) 2004 by Aurelio Bignoli
+#
+# CLSQL users are granted the rights to distribute and use this software
+# as governed by the terms of the Lisp Lesser GNU Public License
+# (http://opensource.franz.com/preamble.html), also known as the LLGPL.
+##########################################################################
+
+
+sqlite3-utils.so: iso-8859-15-coll.c Makefile
+ gcc -c -fPIC iso-8859-15-coll.c -o iso-8859-15-coll.o
+ gcc -shared iso-8859-15-coll.o -o sqlite3-utils.so -l sqlite3
+