summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/NEWS12
-rw-r--r--debian/changelog13
-rwxr-xr-xdebian/clipit-is-dead.sh26
-rw-r--r--debian/control16
-rw-r--r--debian/copyright4
-rwxr-xr-x[-rw-r--r--]debian/install2
-rwxr-xr-xdebian/rules4
7 files changed, 71 insertions, 6 deletions
diff --git a/debian/NEWS b/debian/NEWS
new file mode 100644
index 0000000..2bd0f05
--- /dev/null
+++ b/debian/NEWS
@@ -0,0 +1,12 @@
+clipit (1.4.4+git20190202-2) unstable; urgency=medium
+
+ ClipIt has been deprecated and is no longer supported.
+
+ Diodon is a supported replacement for ClipIt.
+
+ Please note that the user settings cannot be migrated.
+ You can still access them in ~/.config/clipit/clipitrc.
+
+ The original ClipIt binary is shipped as /usr/bin/clipit.real.
+
+ -- Andrej Shadura <andrewsh@debian.org> Sat, 02 May 2020 10:56:40 +0200
diff --git a/debian/changelog b/debian/changelog
index 83d3a0b..1138170 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+clipit (1.4.4+git20190202-2) unstable; urgency=medium
+
+ * Deprecate ClipIt:
+ - Ship a script showing a deprecation notice as /usr/bin/clipit.
+ - Move the real clipit to /usr/bin/clipit.real.
+ - Depend on diodon.
+ - Depend on zenity for the deprecation notice.
+ Closes: #658532, #658533, #679488, #819496, #875903, #903149,
+ #903997, #909309.
+ Diodon will be removed from Debian after Bullseye is released.
+
+ -- Andrej Shadura <andrewsh@debian.org> Sat, 02 May 2020 11:10:53 +0200
+
clipit (1.4.4+git20190202-1) unstable; urgency=medium
* New upstream snapsnot 1.4.4+git20190202.
diff --git a/debian/clipit-is-dead.sh b/debian/clipit-is-dead.sh
new file mode 100755
index 0000000..2ae9341
--- /dev/null
+++ b/debian/clipit-is-dead.sh
@@ -0,0 +1,26 @@
+#!/bin/sh
+
+[ -f ~/.config/clipit/disabled ] && exit 0
+
+DISTRO="Debian"
+
+if [ -f /etc/os-release ]
+then
+ . /etc/os-release
+ DISTRO="${NAME% GNU/Linux}"
+fi
+
+zenity --info --title="ClipIt has been deprecated" --width=500 --window-icon=/usr/share/icons/hicolor/scalable/apps/clipit-trayicon.svg --text="ClipIt has been deprecated and is no longer supported in $DISTRO.
+
+Diodon, a supported replacement for ClipIt, has been automatically installed for your convenience.
+
+Please note that the user settings have not been migrated. You can still access them in <tt>~/.config/clipit/clipitrc</tt>."
+
+if [ -f ~/.config/autostart/clipit-startup.desktop ]
+then
+ sed -i "s,X-GNOME-Autostart-enabled=.*,X-GNOME-Autostart-enabled=false," ~/.config/autostart/clipit-startup.desktop
+fi
+
+mkdir -p ~/.config/clipit
+
+echo "ClipIt has been disabled and replaced by Diodon." > ~/.config/clipit/disabled
diff --git a/debian/control b/debian/control
index 2fd777f..06f6a4e 100644
--- a/debian/control
+++ b/debian/control
@@ -1,8 +1,9 @@
Source: clipit
-Section: misc
+Section: oldlibs
Priority: optional
-Maintainer: Andrej Shadura <andrewsh@debian.org>
+Maintainer: Debian QA Group <packages@qa.debian.org>
Build-Depends: debhelper-compat (= 12)
+ ,dh-exec
,intltool
,libayatana-appindicator3-dev
,libgtk-3-dev
@@ -13,8 +14,8 @@ Vcs-Git: https://salsa.debian.org/debian/clipit.git
Package: clipit
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, xdotool
-Description: lightweight GTK+ clipboard manager
+Depends: ${shlibs:Depends}, ${misc:Depends}, xdotool, zenity, diodon
+Description: lightweight GTK+ clipboard manager (deprecated)
Clipboard manager with features such as:
* Save history of your last copied items
* Search through the history
@@ -23,5 +24,8 @@ Description: lightweight GTK+ clipboard manager
* Exclude specific items from history
.
ClipIt was forked from Parcellite and adds many bugfixes and features to the
- project. For a full list of changes see either the ChangeLog in the package
- or http://clipit.rspwn.com/changelog/
+ project.
+ .
+ Diodon is a replacement for ClipIt, which is no longer supported.
+ .
+ This package may be safely removed after the migration to Diodon is complete.
diff --git a/debian/copyright b/debian/copyright
index ece23bd..5ab3a6d 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -8,6 +8,10 @@ Copyright: 2010-2012 Cristian Henzel <oss@rspwn.com>
2007-2008, Gilberto "Xyhthyx" Miralla <xyhthyx@gmail.com>
License: GPL-3+
+Files: debian/clipit-is-dead.sh
+Copyright: 2020 Andrej Shadura <andrewsh@debian.org>
+License: LGPL-2+ or public-domain
+
Files: debian/icons/*
Copyright: 2019 Andrej Shadura <andrewsh@debian.org>
License: LGPL-2+ or public-domain
diff --git a/debian/install b/debian/install
index 682d343..bb2c53a 100644..100755
--- a/debian/install
+++ b/debian/install
@@ -1 +1,3 @@
+#!/usr/bin/dh-exec
debian/icons usr/share
+debian/clipit-is-dead.sh => usr/bin/clipit
diff --git a/debian/rules b/debian/rules
index 131c740..9815ba6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,5 +21,9 @@ override_dh_autoreconf:
## ~~~~/
intltoolize --automake --copy --force
+override_dh_auto_install:
+ dh_auto_install
+ mv debian/clipit/usr/bin/clipit debian/clipit/usr/bin/clipit.real
+
override_dh_auto_configure:
dh_auto_configure -- --with-gtk3 --enable-appindicator