summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHendrik Tews <hendrik@askra.de>2019-07-23 09:38:37 +0200
committerStéphane Glondu <glondu@debian.org>2023-09-12 07:50:39 +0200
commit42ea1215527e97f44f09525bad8eb6a95b8e8035 (patch)
treeb14595c8dff9cd775e454cc45637a6c037254532
parente2627a439804e96f09c5394c60446aacdb332ed3 (diff)
install without adding execute permissions
Gbp-Pq: Name install-x.patch
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index a3921d7..f1e5b1f 100644
--- a/Makefile
+++ b/Makefile
@@ -41,7 +41,7 @@ install: $(INSTALL-TARGETS)
install-doc:
$(INSTALL) -d "$(DOCDIR)/odoc-pages"
- $(INSTALL) CHANGES.md LICENSE.md README.md "$(DOCDIR)"
+ $(INSTALL) -m 644 CHANGES.md LICENSE.md README.md "$(DOCDIR)"
$(INSTALL) doc/index.mld doc/cli.mld doc/examples.mld doc/tutorial.mld \
doc/tool_man.mld "$(DOCDIR)/odoc-pages"
@@ -61,18 +61,18 @@ create-libdir:
$(INSTALL) -d "$(LIBDIR)"
install-common: create-libdir
- $(INSTALL) pkg/META $(BASE).mli $(BASE).cmi $(BASE).cmti "$(LIBDIR)"
- $(INSTALL) cmdliner.opam "$(LIBDIR)/opam"
+ $(INSTALL) -m 644 pkg/META $(BASE).mli $(BASE).cmi $(BASE).cmti "$(LIBDIR)"
+ $(INSTALL) -m 644 cmdliner.opam "$(LIBDIR)/opam"
install-byte: create-libdir
- $(INSTALL) $(BASE).cma "$(LIBDIR)"
+ $(INSTALL) -m 644 $(BASE).cma "$(LIBDIR)"
install-native: create-libdir
- $(INSTALL) $(BASE).cmxa $(BASE)$(EXT_LIB) $(wildcard $(B)/cmdliner*.cmx) \
+ $(INSTALL) -m 644 $(BASE).cmxa $(BASE)$(EXT_LIB) $(wildcard $(B)/cmdliner*.cmx) \
"$(LIBDIR)"
install-native-dynlink: create-libdir
- $(INSTALL) $(BASE).cmxs "$(LIBDIR)"
+ $(INSTALL) -m 644 $(BASE).cmxs "$(LIBDIR)"
.PHONY: all install install-doc clean build-byte build-native \
build-native-dynlink create-libdir install-common install-byte \