summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2020-06-25 10:44:28 +0100
committerSimon McVittie <smcv@debian.org>2020-06-25 10:44:28 +0100
commit1ac10dc816667ddc4f31da4945f1551a323243bc (patch)
tree7aa5c1d83a449968ddaf81795854be93681e21f0
parentbb04c7ffa880f30e1d0f176f748913f5a86e0b78 (diff)
Drop all patches, applied upstream
-rw-r--r--debian/patches/Fix-building-against-libglvnd-provided-EGL-headers.patch59
-rw-r--r--debian/patches/Normally-skip-tests-that-are-not-expected-to-succeed.patch111
-rw-r--r--debian/patches/Terminate-tests-with-SIGALRM-if-they-take-more-than-120-s.patch64
-rw-r--r--debian/patches/series6
-rw-r--r--debian/patches/test-premult-Don-t-free-texture-data-until-CoglBitmap-is-.patch98
-rw-r--r--debian/patches/tests-Show-the-actual-output-from-tests-if-VERBOSE-is-set.patch46
-rw-r--r--debian/patches/tests-Use-tmp-file-to-dump-test-results.patch61
7 files changed, 0 insertions, 445 deletions
diff --git a/debian/patches/Fix-building-against-libglvnd-provided-EGL-headers.patch b/debian/patches/Fix-building-against-libglvnd-provided-EGL-headers.patch
deleted file mode 100644
index c1408413..00000000
--- a/debian/patches/Fix-building-against-libglvnd-provided-EGL-headers.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From: Alexander Tsoy <alexander@tsoy.me>
-Date: Tue, 29 Oct 2019 18:17:51 +0300
-Subject: Fix building against libglvnd-provided EGL headers
-
-Add missing EGL/eglmesaext.h include. When building against mesa-provided
-headers, this header is included indirectly via EGL/eglext.h.
-
-Also fix typo COGL_EGL_INCLUDE -> COGL_EGL_INCLUDES
-
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/17
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/19
----
- configure.ac | 16 ++++++++++++++--
- 1 file changed, 14 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 956f277..6c44eea 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -685,10 +685,15 @@ AS_IF([test "x$enable_gles1" = "xyes"],
- AC_SUBST([COGL_EGL_INCLUDES])
-
- AC_CHECK_HEADERS([EGL/eglext.h],
-- [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDE
-+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
- #include <EGL/eglext.h>"],
- [],
- [$COGL_EGL_INCLUDES])
-+ AC_CHECK_HEADERS([EGL/eglmesaext.h],
-+ [COGL_EGL_INCLUDES="$COGL_EGL_INCLUDES
-+#include <EGL/eglmesaext.h>"],
-+ [],
-+ [$COGL_EGL_INCLUDES])
-
- # Check for a GLES 1.x Common Profile library with/without EGL.
- #
-@@ -1216,6 +1221,12 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
- [],
- [AC_MSG_ERROR([Unable to locate required EGL headers])],
- [#include <EGL/egl.h>])
-+ AC_CHECK_HEADERS(
-+ [EGL/eglmesaext.h],
-+ [],
-+ [AC_MSG_ERROR([Unable to locate required EGL headers])],
-+ [#include <EGL/egl.h>
-+#include <EGL/eglext.h>])
-
- AC_CHECK_LIB(EGL, [eglInitialize],
- [COGL_EXTRA_LDFLAGS="$COGL_EXTRA_LDFLAGS -lEGL"],
-@@ -1226,7 +1237,8 @@ AS_IF([test "x$NEED_EGL" = "xyes" && test "x$EGL_CHECKED" != "xyes"],
- )
-
- COGL_EGL_INCLUDES="#include <EGL/egl.h>
--#include <EGL/eglext.h>"
-+#include <EGL/eglext.h>
-+#include <EGL/eglmesaext.h>"
- AC_SUBST([COGL_EGL_INCLUDES])
- ])
-
diff --git a/debian/patches/Normally-skip-tests-that-are-not-expected-to-succeed.patch b/debian/patches/Normally-skip-tests-that-are-not-expected-to-succeed.patch
deleted file mode 100644
index 3445393c..00000000
--- a/debian/patches/Normally-skip-tests-that-are-not-expected-to-succeed.patch
+++ /dev/null
@@ -1,111 +0,0 @@
-From: Simon McVittie <smcv@debian.org>
-Date: Sun, 25 Aug 2019 16:53:31 +0100
-Subject: Normally skip tests that are not expected to succeed
-
-If a test is not expected to succeed, then running it could be considered
-to be a waste of resources, particularly if the failure might manifest
-as an indefinite hang (see !11), or if the test is likely to dump core
-and trigger "expensive" crash-reporting mechanisms like systemd-coredump,
-corekeeper, abrt or apport.
-
-Skip the tests that are expected to fail. They can still be requested via
-an environment variable, which can be set after fixing a bug to check which
-tests are now passing.
-
-Signed-off-by: Simon McVittie <smcv@debian.org>
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/-/merge_requests/15
----
- test-fixtures/test-utils.c | 4 +++-
- test-fixtures/test-utils.h | 2 +-
- tests/conform/test-conform-main.c | 15 +++++++++++----
- tests/unit/test-unit-main.c | 18 ++++++++++++------
- 4 files changed, 27 insertions(+), 12 deletions(-)
-
-diff --git a/test-fixtures/test-utils.c b/test-fixtures/test-utils.c
-index faa9e1f..d6c592c 100644
---- a/test-fixtures/test-utils.c
-+++ b/test-fixtures/test-utils.c
-@@ -129,7 +129,7 @@ is_boolean_env_set (const char *variable)
- return ret;
- }
-
--void
-+CoglBool
- test_utils_init (TestFlags requirement_flags,
- TestFlags known_failure_flags)
- {
-@@ -213,6 +213,8 @@ test_utils_init (TestFlags requirement_flags,
- g_print ("WARNING: Missing required feature[s] for this test\n");
- else if (known_failure)
- g_print ("WARNING: Test is known to fail\n");
-+
-+ return (!missing_requirement && !known_failure);
- }
-
- void
-diff --git a/test-fixtures/test-utils.h b/test-fixtures/test-utils.h
-index 9c3ced9..e59163c 100644
---- a/test-fixtures/test-utils.h
-+++ b/test-fixtures/test-utils.h
-@@ -69,7 +69,7 @@ typedef enum {
- extern CoglContext *test_ctx;
- extern CoglFramebuffer *test_fb;
-
--void
-+CoglBool
- test_utils_init (TestFlags requirement_flags,
- TestFlags known_failure_flags);
-
-diff --git a/tests/conform/test-conform-main.c b/tests/conform/test-conform-main.c
-index ee66899..63ae15f 100644
---- a/tests/conform/test-conform-main.c
-+++ b/tests/conform/test-conform-main.c
-@@ -15,10 +15,17 @@
- extern void FUNC (void); \
- if (strcmp (#FUNC, argv[1]) == 0) \
- { \
-- test_utils_init (REQUIREMENTS, KNOWN_FAIL_REQUIREMENTS); \
-- FUNC (); \
-- test_utils_fini (); \
-- exit (0); \
-+ if (test_utils_init (REQUIREMENTS, KNOWN_FAIL_REQUIREMENTS) \
-+ || g_getenv ("COGL_TEST_TRY_EVERYTHING") != NULL) \
-+ { \
-+ FUNC (); \
-+ test_utils_fini (); \
-+ exit (0); \
-+ } \
-+ else \
-+ { \
-+ exit (1); \
-+ } \
- } \
- } G_STMT_END
-
-diff --git a/tests/unit/test-unit-main.c b/tests/unit/test-unit-main.c
-index b1f7864..6065b08 100644
---- a/tests/unit/test-unit-main.c
-+++ b/tests/unit/test-unit-main.c
-@@ -36,10 +36,16 @@ main (int argc, char **argv)
- return 1;
- }
-
-- test_utils_init (unit_test->requirement_flags,
-- unit_test->known_failure_flags);
-- unit_test->run ();
-- test_utils_fini ();
--
-- return 0;
-+ if (test_utils_init (unit_test->requirement_flags,
-+ unit_test->known_failure_flags)
-+ || g_getenv ("COGL_TEST_TRY_EVERYTHING") != NULL)
-+ {
-+ unit_test->run ();
-+ test_utils_fini ();
-+ return 0;
-+ }
-+ else
-+ {
-+ return 1;
-+ }
- }
diff --git a/debian/patches/Terminate-tests-with-SIGALRM-if-they-take-more-than-120-s.patch b/debian/patches/Terminate-tests-with-SIGALRM-if-they-take-more-than-120-s.patch
deleted file mode 100644
index 756ce8e5..00000000
--- a/debian/patches/Terminate-tests-with-SIGALRM-if-they-take-more-than-120-s.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From: Simon McVittie <smcv@debian.org>
-Date: Sat, 24 Aug 2019 15:48:46 +0100
-Subject: Terminate tests with SIGALRM if they take more than 120 seconds
-
-The Debian autobuilders run cogl's build-time tests to get an idea of
-how much can be expected to work on each supported architecture.
-We're currently ignoring test failures and running the tests for
-information only, but if a test hangs, that will still cause the build
-to fail (and tie up an autobuilder until a rather long timeout is
-reached).
-
-The fork of cogl in Mutter uses a 120 second timeout for tests in its
-Meson build system, but other than that it's purely an arbitrary number.
-dbus uses a similar alarm()-based watchdog, as do a couple of tests
-in GLib.
-
-Bug-Debian: https://bugs.debian.org/935592
-Signed-off-by: Simon McVittie <smcv@debian.org>
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/merge_requests/11
----
- configure.ac | 2 ++
- test-fixtures/test-utils.c | 9 +++++++++
- 2 files changed, 11 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 9fc1505..956f277 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1361,6 +1361,8 @@ dnl ================================================================
- dnl Checks for library functions.
- dnl ================================================================
-
-+AC_CHECK_FUNCS_ONCE([alarm])
-+
- dnl The 'ffs' function is part of C99 so it isn't always
- dnl available. Cogl has a fallback if needed.
- dnl
-diff --git a/test-fixtures/test-utils.c b/test-fixtures/test-utils.c
-index 59e3fd8..faa9e1f 100644
---- a/test-fixtures/test-utils.c
-+++ b/test-fixtures/test-utils.c
-@@ -2,6 +2,10 @@
-
- #include <stdlib.h>
-
-+#ifdef HAVE_UNISTD_H
-+#include <unistd.h>
-+#endif
-+
- #include "test-unit.h"
- #include "test-utils.h"
-
-@@ -146,6 +150,11 @@ test_utils_init (TestFlags requirement_flags,
- "$ make test-report");
- counter++;
-
-+#ifdef HAVE_ALARM
-+ /* Kill the test with SIGALRM if it takes more than this many seconds */
-+ alarm (120);
-+#endif
-+
- if (is_boolean_env_set ("COGL_TEST_VERBOSE") ||
- is_boolean_env_set ("V"))
- cogl_test_is_verbose = TRUE;
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 940391d8..00000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,6 +0,0 @@
-test-premult-Don-t-free-texture-data-until-CoglBitmap-is-.patch
-Terminate-tests-with-SIGALRM-if-they-take-more-than-120-s.patch
-tests-Use-tmp-file-to-dump-test-results.patch
-tests-Show-the-actual-output-from-tests-if-VERBOSE-is-set.patch
-Normally-skip-tests-that-are-not-expected-to-succeed.patch
-Fix-building-against-libglvnd-provided-EGL-headers.patch
diff --git a/debian/patches/test-premult-Don-t-free-texture-data-until-CoglBitmap-is-.patch b/debian/patches/test-premult-Don-t-free-texture-data-until-CoglBitmap-is-.patch
deleted file mode 100644
index c4027f93..00000000
--- a/debian/patches/test-premult-Don-t-free-texture-data-until-CoglBitmap-is-.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From: Simon McVittie <smcv@debian.org>
-Date: Sun, 25 Aug 2019 16:44:07 +0100
-Subject: test-premult: Don't free texture data until CoglBitmap is freed
-
-According to the cogl_bitmap_new_for_data documentation, the data is not
-copied, so the application must keep the buffer alive for the lifetime
-of the CoglBitmap. Freeing it too early led to a use-after-free in the
-cogl unit tests. With that fixed, the test passes, so remove the known
-failure annotation.
-
-==6223==ERROR: AddressSanitizer: heap-use-after-free on address 0x62100001a500 at pc 0x7f3e2d4e7f4e bp 0x7ffcd9c41f30 sp 0x7ffcd9c416e0
-READ of size 4096 at 0x62100001a500 thread T0
- #0 0x7f3e2d4e7f4d (/usr/lib/x86_64-linux-gnu/libasan.so.5+0x96f4d)
- #1 0x7f3e260c7f6b in util_copy_box ../src/gallium/auxiliary/util/u_surface.c:131
- #2 0x7f3e268c6c10 in u_default_texture_subdata ../src/gallium/auxiliary/util/u_transfer.c:67
- #3 0x7f3e26486459 in st_TexSubImage ../src/mesa/state_tracker/st_cb_texture.c:1480
- #4 0x7f3e26487029 in st_TexImage ../src/mesa/state_tracker/st_cb_texture.c:1709
- #5 0x7f3e26487029 in st_TexImage ../src/mesa/state_tracker/st_cb_texture.c:1691
- #6 0x7f3e2644bdba in teximage ../src/mesa/main/teximage.c:3105
- #7 0x7f3e2644bdba in teximage_err ../src/mesa/main/teximage.c:3132
- #8 0x7f3e2644d84f in _mesa_TexImage2D ../src/mesa/main/teximage.c:3170
- #9 0x7f3e2cd1f7df in _cogl_texture_driver_upload_to_gl driver/gl/gl/cogl-texture-driver-gl.c:347
- #10 0x7f3e2ccd441b in allocate_from_bitmap driver/gl/cogl-texture-2d-gl.c:255
- #11 0x7f3e2ccd441b in _cogl_texture_2d_gl_allocate driver/gl/cogl-texture-2d-gl.c:462
- #12 0x7f3e2ce3a6c0 in cogl_texture_allocate cogl/cogl-texture.c:1398
- #13 0x7f3e2ce3e116 in _cogl_texture_pre_paint cogl/cogl-texture.c:359
- #14 0x7f3e2cdee177 in _cogl_pipeline_layer_pre_paint cogl/cogl-pipeline-layer.c:864
- #15 0x7f3e2cd574af in _cogl_rectangles_validate_layer_cb cogl/cogl-primitives.c:542
- #16 0x7f3e2cdd742f in cogl_pipeline_foreach_layer cogl/cogl-pipeline.c:735
- #17 0x7f3e2cd5c8b0 in _cogl_framebuffer_draw_multitextured_rectangles cogl/cogl-primitives.c:658
- #18 0x7f3e2cd60152 in cogl_rectangle cogl/cogl-primitives.c:858
- #19 0x5570a71ed6a0 in check_texture tests/conform/test-premult.c:103
- #20 0x5570a71ed946 in test_premult tests/conform/test-premult.c:159
- #21 0x5570a71df0d6 in main tests/conform/test-conform-main.c:58
- #22 0x7f3e2bcd809a in __libc_start_main ../csu/libc-start.c:308
- #23 0x5570a71e0869 in _start (/home/smcv/src/debian/cogl/tests/conform/.libs/test-conformance+0x33869)
-
-0x62100001a500 is located 0 bytes inside of 4096-byte region [0x62100001a500,0x62100001b500)
-freed by thread T0 here:
- #0 0x7f3e2d5581d7 in __interceptor_free (/usr/lib/x86_64-linux-gnu/libasan.so.5+0x1071d7)
- #1 0x5570a71ed58b in make_texture tests/conform/test-premult.c:69
-
-previously allocated by thread T0 here:
- #0 0x7f3e2d558588 in malloc (/usr/lib/x86_64-linux-gnu/libasan.so.5+0x107588)
- #1 0x7f3e2d384500 in g_malloc ../../../glib/gmem.c:99
-
-Signed-off-by: Simon McVittie <smcv@debian.org>
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/merge_requests/12
-Applied-upstream: 1.22.7, commit:0f5f3179c0b59b7c03339d39a0661f07aab37e6e
----
- tests/conform/test-conform-main.c | 2 +-
- tests/conform/test-premult.c | 6 +++++-
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/tests/conform/test-conform-main.c b/tests/conform/test-conform-main.c
-index 9b6573d..ee66899 100644
---- a/tests/conform/test-conform-main.c
-+++ b/tests/conform/test-conform-main.c
-@@ -55,7 +55,7 @@ main (int argc, char **argv)
- ADD_TEST (test_pipeline_user_matrix, 0, 0);
- ADD_TEST (test_blend_strings, 0, 0);
- ADD_TEST (test_blend, 0, 0);
-- ADD_TEST (test_premult, 0, TEST_KNOWN_FAILURE);
-+ ADD_TEST (test_premult, 0, 0);
- UNPORTED_TEST (test_readpixels);
- #ifdef COGL_HAS_COGL_PATH_SUPPORT
- ADD_TEST (test_path, 0, 0);
-diff --git a/tests/conform/test-premult.c b/tests/conform/test-premult.c
-index fa60bdf..9ac7b68 100644
---- a/tests/conform/test-premult.c
-+++ b/tests/conform/test-premult.c
-@@ -49,6 +49,7 @@ make_texture (uint32_t color,
- CoglPixelFormat src_format,
- MakeTextureFlags flags)
- {
-+ static CoglUserDataKey bitmap_free_key;
- CoglTexture2D *tex_2d;
- guchar *tex_data = gen_tex_data (color);
- CoglBitmap *bmp = cogl_bitmap_new_for_data (test_ctx,
-@@ -57,6 +58,10 @@ make_texture (uint32_t color,
- src_format,
- QUAD_WIDTH * 4,
- tex_data);
-+ cogl_object_set_user_data (COGL_OBJECT (bmp),
-+ &bitmap_free_key,
-+ tex_data,
-+ g_free);
-
- tex_2d = cogl_texture_2d_new_from_bitmap (bmp);
-
-@@ -66,7 +71,6 @@ make_texture (uint32_t color,
- cogl_texture_set_premultiplied (tex_2d, FALSE);
-
- cogl_object_unref (bmp);
-- g_free (tex_data);
-
- return tex_2d;
- }
diff --git a/debian/patches/tests-Show-the-actual-output-from-tests-if-VERBOSE-is-set.patch b/debian/patches/tests-Show-the-actual-output-from-tests-if-VERBOSE-is-set.patch
deleted file mode 100644
index 006f2668..00000000
--- a/debian/patches/tests-Show-the-actual-output-from-tests-if-VERBOSE-is-set.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From: Simon McVittie <smcv@debian.org>
-Date: Sat, 24 Aug 2019 15:37:29 +0100
-Subject: tests: Show the actual output from tests if VERBOSE is set
-
-Writing tests' output to a log file makes them difficult to debug when
-the test might be running on an autobuilder or CI system where only
-stdout/stderr are recorded. This is particularly troublesome if a
-failure is only reproducible on a particular autobuilder.
-
-Recent Automake versions have the convention that detailed output from
-failing tests is written to stdout/stderr, not just to log files, when
-the VERBOSE environment variable is set; borrow that convention as a
-trigger for producing detailed test output.
-
-Signed-off-by: Simon McVittie <smcv@debian.org>
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/merge_requests/14
----
- tests/run-tests.sh | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/tests/run-tests.sh b/tests/run-tests.sh
-index 763e173..3c02eb4 100755
---- a/tests/run-tests.sh
-+++ b/tests/run-tests.sh
-@@ -1,5 +1,7 @@
- #!/bin/bash
-
-+set -o pipefail
-+
- if test -z "$G_DEBUG"; then
- G_DEBUG=fatal-warnings
- else
-@@ -64,7 +66,12 @@ get_status()
-
- run_test()
- {
-- $($TEST_BINARY $1 &> "$LOG")
-+ if [ -n "${VERBOSE-}" ]; then
-+ echo "running $TEST_BINARY $1:"
-+ $TEST_BINARY $1 2>&1 | tee "$LOG"
-+ else
-+ $($TEST_BINARY $1 &> "$LOG")
-+ fi
- TMP=$?
- var_name=$2_result
- eval $var_name=$TMP
diff --git a/debian/patches/tests-Use-tmp-file-to-dump-test-results.patch b/debian/patches/tests-Use-tmp-file-to-dump-test-results.patch
deleted file mode 100644
index c4d4b9d4..00000000
--- a/debian/patches/tests-Use-tmp-file-to-dump-test-results.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
-Date: Mon, 17 Dec 2018 13:12:29 -0200
-Subject: tests: Use tmp file to dump test results
-
-When running installed tests, the working directory for Cogl tests is
-in /usr/libexec/installed-tests, which isn't writable by normal users.
-
-To avoid the adding stray hidden files to the current directory,
-adapt the runner script to fallback to $(mktemp) - which is
-available on all platform we care about - and avoid adding
-hidden files everywhere.
-
-(Originally commit 05ab8eebe8f37d437fb915a2dafe0c0bb68e3950 in mutter's
-fork of cogl.)
-
-Forwarded: https://gitlab.gnome.org/GNOME/cogl/merge_requests/10
----
- tests/run-tests.sh | 10 +++++++---
- 1 file changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/tests/run-tests.sh b/tests/run-tests.sh
-index 7e62bf0..763e173 100755
---- a/tests/run-tests.sh
-+++ b/tests/run-tests.sh
-@@ -18,6 +18,8 @@ shift
-
- set +m
-
-+LOG=$(mktemp)
-+
- trap "" ERR
- trap "" SIGABRT
- trap "" SIGFPE
-@@ -62,17 +64,17 @@ get_status()
-
- run_test()
- {
-- $($TEST_BINARY $1 &>.log)
-+ $($TEST_BINARY $1 &> "$LOG")
- TMP=$?
- var_name=$2_result
- eval $var_name=$TMP
-- if grep -q "$MISSING_FEATURE" .log; then
-+ if grep -q "$MISSING_FEATURE" "$LOG"; then
- if test $TMP -ne 0; then
- eval $var_name=500
- else
- eval $var_name=400
- fi
-- elif grep -q "$KNOWN_FAILURE" .log; then
-+ elif grep -q "$KNOWN_FAILURE" "$LOG"; then
- if test $TMP -ne 0; then
- eval $var_name=300
- else
-@@ -154,4 +156,6 @@ do
- echo ""
- done
-
-+rm "$LOG"
-+
- exit $EXIT