summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-05-16 21:31:09 +0000
committerVagrant Cascadian <vagrant@debian.org>2022-05-16 15:09:21 -0700
commitf02aa61edcb6d799108dd59441c61ffa66038f8f (patch)
tree66d5da6399355a0b1650646f7981e16958d39b42
parent4415f322ae04d34ee5ba3348df97c8f62a197c82 (diff)
debian/rules: Pass -ffile-prefix-map in CFLAGS to avoid embedding
build paths. (Closes: #1011104) https://reproducible-builds.org/docs/build-path/
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 60c65ac..d18f93e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,10 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
else
CFLAGS += -O2
endif
+
+# Avoid embedding the build path for reproducible builds
+CFLAGS += -ffile-prefix-map=$(CURDIR)=.
+
export CFLAGS