summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMehdi Dogguy <mehdi@debian.org>2018-09-14 07:26:51 +0200
committerMehdi Dogguy <mehdi@debian.org>2018-09-14 07:26:51 +0200
commit416abc291f17f06e40d0bbc9e2d3cd6ba20e265c (patch)
treec45deed7c31224713fdfced8c07ad7cdd0ce83bd
parent2547856cde0deb2b0a5cefa324f9d15ea30cd046 (diff)
Fix issue on arm{el,hf} and ppc64el (Closes: #907431)
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/0001-Fix-typo-in-cppo-s-parser.patch23
-rw-r--r--debian/patches/series1
3 files changed, 32 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ce509db..660fe63 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+cppo (1.6.4-2) UNRELEASED; urgency=medium
+
+ * Team upload.
+ * Fix issue on arm{el,hf} and ppc64el (Closes: #907431)
+ - add patch 0001-Fix-typo-in-cppo-s-parser.patch from upstream
+
+ -- Mehdi Dogguy <mehdi@debian.org> Fri, 14 Sep 2018 07:25:06 +0200
+
cppo (1.6.4-1) unstable; urgency=medium
* Team upload.
diff --git a/debian/patches/0001-Fix-typo-in-cppo-s-parser.patch b/debian/patches/0001-Fix-typo-in-cppo-s-parser.patch
new file mode 100644
index 0000000..3bcf400
--- /dev/null
+++ b/debian/patches/0001-Fix-typo-in-cppo-s-parser.patch
@@ -0,0 +1,23 @@
+From: Mehdi Dogguy <mehdi@debian.org>
+Date: Fri, 14 Sep 2018 07:22:39 +0200
+Subject: Fix typo in cppo's parser
+
+Bug-Debian: https://bugs.debian.org/907431
+Forwarded: https://github.com/mjambon/cppo/issues/61
+---
+ src/cppo_parser.mly | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/cppo_parser.mly b/src/cppo_parser.mly
+index 526f66d..21d2cdd 100644
+--- a/src/cppo_parser.mly
++++ b/src/cppo_parser.mly
+@@ -252,7 +252,7 @@ aexpr:
+ | aexpr MOD aexpr { `Mod ($2, $1, $3) }
+ | aexpr LSL aexpr { `Lsl ($1, $3) }
+ | aexpr LSR aexpr { `Lsr ($1, $3) }
+- | aexpr ASR aexpr { `Lsr ($1, $3) }
++ | aexpr ASR aexpr { `Asr ($1, $3) }
+ | aexpr LAND aexpr { `Land ($1, $3) }
+ | aexpr LOR aexpr { `Lor ($1, $3) }
+ | aexpr LXOR aexpr { `Lxor ($1, $3) }
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..b64c90c
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Fix-typo-in-cppo-s-parser.patch