summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@ringlet.net>2021-02-12 02:14:01 +0200
committerPeter Pentchev <roam@debian.org>2021-02-12 02:14:01 +0200
commit23b62d1ff1b9007db391a532afdf9588b8eb53b1 (patch)
tree366c3a730134e5a54fbde37f6b8ff68dbf250ccc
parent10142290692a62931a4aebb1a34cce02a3f74fc8 (diff)
Fall back to nosetests3, not nosetests.
Forwarded: not-needed Last-Update: 2018-10-30 Gbp-Pq: Name nosetests3.patch
-rw-r--r--tests/python/tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/python/tests/CMakeLists.txt b/tests/python/tests/CMakeLists.txt
index 3c1fdb7..46adfac 100644
--- a/tests/python/tests/CMakeLists.txt
+++ b/tests/python/tests/CMakeLists.txt
@@ -7,8 +7,8 @@ execute_process(COMMAND nosetests${NOSETEST_VERSION_SUFFIX} --help
OUTPUT_QUIET ERROR_QUIET
RESULT_VARIABLE NOSE_CHECK_RESULT)
IF (NOT NOSE_CHECK_RESULT STREQUAL "0")
- MESSAGE("Command 'nosetests${NOSETEST_VERSION_SUFFIX}' doesn't exist! Using only 'nosetests' instead")
- SET(NOSETEST_VERSION_SUFFIX "")
+ MESSAGE("Command 'nosetests${NOSETEST_VERSION_SUFFIX}' doesn't exist! Using only 'nosetests3' instead")
+ SET(NOSETEST_VERSION_SUFFIX "3")
ENDIF()
CONFIGURE_FILE("run_nosetests.sh.in" "${CMAKE_BINARY_DIR}/tests/python/tests/run_nosetests.sh")