summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@ringlet.net>2020-10-18 18:05:53 +0300
committerPeter Pentchev <roam@debian.org>2020-10-18 18:05:53 +0300
commit2d9f66f6b8cb2f611506b6b8d447bb0451b90e0b (patch)
treec0c370cb8a1eea5c5551cb54b6d3b40d217dc547
parenta39d98590777ac3767e9319a2e4fb6751e40742f (diff)
Fall back to nosetests3, not nosetests.archive/debian/0.16.1-1
Forwarded: not-needed Last-Update: 2018-10-30 Gbp-Pq: Name nosetests3.patch
-rw-r--r--tests/python/tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/python/tests/CMakeLists.txt b/tests/python/tests/CMakeLists.txt
index 3c1fdb7..46adfac 100644
--- a/tests/python/tests/CMakeLists.txt
+++ b/tests/python/tests/CMakeLists.txt
@@ -7,8 +7,8 @@ execute_process(COMMAND nosetests${NOSETEST_VERSION_SUFFIX} --help
OUTPUT_QUIET ERROR_QUIET
RESULT_VARIABLE NOSE_CHECK_RESULT)
IF (NOT NOSE_CHECK_RESULT STREQUAL "0")
- MESSAGE("Command 'nosetests${NOSETEST_VERSION_SUFFIX}' doesn't exist! Using only 'nosetests' instead")
- SET(NOSETEST_VERSION_SUFFIX "")
+ MESSAGE("Command 'nosetests${NOSETEST_VERSION_SUFFIX}' doesn't exist! Using only 'nosetests3' instead")
+ SET(NOSETEST_VERSION_SUFFIX "3")
ENDIF()
CONFIGURE_FILE("run_nosetests.sh.in" "${CMAKE_BINARY_DIR}/tests/python/tests/run_nosetests.sh")