summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Blaha <mblaha@redhat.com>2021-04-21 15:37:31 +0200
committeramatej <matej.ales@seznam.cz>2021-04-22 07:20:37 +0200
commit394438b0d39a6794723aca6be58757596a648248 (patch)
tree3c57ff09e519428c585ed9d7857a5a5386b43b60
parent69b2be23d46a9eb3a03ffff0a990a2ffbc3b63f9 (diff)
CI: Add pip to packages Python CI installs
python3-pip is just a weak dependence of python3. In case the python3 was installed without weakdeps in base container and did not get upgraded during `dnf builddep`, the pip command is missing.
-rw-r--r--.github/workflows/ci-python.yml2
1 files changed, 1 insertions, 1 deletions
diff --git a/.github/workflows/ci-python.yml b/.github/workflows/ci-python.yml
index b3b39a1..0603861 100644
--- a/.github/workflows/ci-python.yml
+++ b/.github/workflows/ci-python.yml
@@ -12,7 +12,7 @@ jobs:
- name: Install dependencies
run: |
- sudo dnf -y install dnf-plugins-core
+ sudo dnf -y install dnf-plugins-core python3-pip
sudo dnf -y builddep createrepo_c.spec
pip install --upgrade pip
pip install pytest