summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@ringlet.net>2020-11-29 18:23:14 +0200
committerPeter Pentchev <roam@debian.org>2020-11-29 18:23:14 +0200
commite9e9bc0923067ff4fe664eefa6b136852b28363e (patch)
tree5edc86c2f4c3d82829b55ea854d712c4a899cbe2
parent20ac21931e1ddfd3c3d85a33db3e6ca743dd0d8c (diff)
Fall back to nosetests3, not nosetests.
Forwarded: not-needed Last-Update: 2018-10-30 Gbp-Pq: Name nosetests3.patch
-rw-r--r--tests/python/tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/python/tests/CMakeLists.txt b/tests/python/tests/CMakeLists.txt
index 3c1fdb7..46adfac 100644
--- a/tests/python/tests/CMakeLists.txt
+++ b/tests/python/tests/CMakeLists.txt
@@ -7,8 +7,8 @@ execute_process(COMMAND nosetests${NOSETEST_VERSION_SUFFIX} --help
OUTPUT_QUIET ERROR_QUIET
RESULT_VARIABLE NOSE_CHECK_RESULT)
IF (NOT NOSE_CHECK_RESULT STREQUAL "0")
- MESSAGE("Command 'nosetests${NOSETEST_VERSION_SUFFIX}' doesn't exist! Using only 'nosetests' instead")
- SET(NOSETEST_VERSION_SUFFIX "")
+ MESSAGE("Command 'nosetests${NOSETEST_VERSION_SUFFIX}' doesn't exist! Using only 'nosetests3' instead")
+ SET(NOSETEST_VERSION_SUFFIX "3")
ENDIF()
CONFIGURE_FILE("run_nosetests.sh.in" "${CMAKE_BINARY_DIR}/tests/python/tests/run_nosetests.sh")