summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTino Mettler <tino+debian@tikei.de>2024-01-25 18:17:56 +0100
committerTino Mettler <tino+debian@tikei.de>2024-02-17 20:38:19 +0100
commit127511e15308d608ccb7f077279e9c117efb5592 (patch)
treea20d1249e42fdd1b05757d066c5af138abe7b848
parent5617c3a74181e8c73e82dfb3f4105fb6d6767c8b (diff)
Restructure configure options
This makes the list of configure options and corresponding changes more readable.
-rwxr-xr-xdebian/rules16
1 files changed, 10 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index a56c5b39f..6aef102c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,16 +16,20 @@ else
export DEB_CXXFLAGS_MAINT_APPEND=-O3
endif
+ifneq ($(DEB_HOST_ARCH),arm64)
+ # Disable OPENMP for arm64 builds. See LP: #2038351
+ DISABLE_OPENMP = -DUSE_OPENMP=OFF
+endif
+
%:
dh $@
override_dh_auto_configure: cmake/version.cmake
-ifeq ($(DEB_HOST_ARCH),arm64)
- # Disable OPENMP for arm64 builds. See LP: #2038351
- dh_auto_configure -- -DBINARY_PACKAGE_BUILD=1 -DCMAKE_BUILD_TYPE=Release -DRAWSPEED_ENABLE_LTO=ON -DUSE_OPENMP=OFF
-else
- dh_auto_configure -- -DBINARY_PACKAGE_BUILD=1 -DCMAKE_BUILD_TYPE=Release -DRAWSPEED_ENABLE_LTO=ON
-endif
+ dh_auto_configure -- \
+ -DBINARY_PACKAGE_BUILD=1 \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DRAWSPEED_ENABLE_LTO=ON \
+ $(DISABLE_OPENMP)
describe-current-version:
git describe --tags upstream | sed 's,^release-,,;s,-,+,;s,-,~,;'