summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 641dda5..27ec432 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,13 @@
SUBDIRS = src doc
EXTRA_DIST = autogen.sh TODO DEVICES.txt dfuse-pack.py
+
+wwwman: www/dfu-util.1.html www/dfu-suffix.1.html www/dfu-prefix.1.html
+
+www/%.1.html : doc/%.1
+ pandoc -f man -t html -s -o $@ $^
+
+pdfman: dfu-util.1.man.pdf dfu-prefix.1.man.pdf dfu-suffix.1.man.pdf
+
+%.1.man.pdf: doc/%.1
+ man -Tpdf $^ > $@