summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/c++11.patch19
-rw-r--r--debian/patches/series1
2 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/c++11.patch b/debian/patches/c++11.patch
new file mode 100644
index 0000000..7452b6a
--- /dev/null
+++ b/debian/patches/c++11.patch
@@ -0,0 +1,19 @@
+Description: Build using C++11
+ required for lilv
+Author: IOhannes m zmölnig
+Origin: Debian
+Forwarded: no
+Last-Update: 2021-11-29
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- ecasound.orig/configure.ac
++++ ecasound/configure.ac
+@@ -82,7 +82,7 @@
+ dnl ---
+ EXTRACPPFLAGS="-D_REENTRANT -D_XOPEN_SOURCE=600"
+ EXTRAGCCFLAGS="-ffast-math -fstrict-aliasing"
+-EXTRACXXFLAGS="-std=c++98"
++EXTRACXXFLAGS="-std=c++11"
+ if test x${GXX} = xyes; then
+ AM_CXXFLAGS="$AM_CXXFLAGS $EXTRAGCCFLAGS"
+ AM_CFLAGS="$AM_CFLAGS $EXTRAGCCFLAGS"
diff --git a/debian/patches/series b/debian/patches/series
index a0b438c..0f40342 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -3,3 +3,4 @@
04_fix-spelling.patch
0004-Change-shebang-of-tests-to-python3.patch
0005-ecasignalview.cpp-always-use-s-style-format-for-prin.patch
+c++11.patch