summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Browning <rlb@defaultvalue.org>2022-06-11 12:55:26 -0500
committerRob Browning <rlb@defaultvalue.org>2022-09-12 14:30:47 -0500
commitddfad72dca728e1a4ef4ab19dd5ff52b5cb41657 (patch)
treebde6fe639d7ff77435dc620b5ffea6b6981f5dd3
parent230f254e5b2f81eb18060ccda7e3e1c0c2c91ca9 (diff)
debian/rules: rely on dpkg pkg-info.mk for src_name and debian_ver
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 30c8738c93d..fa5a74d791f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,8 @@
# Debhelper support added via one of Joey Hess' example files.
# See the debian/changelog for further historical information.
+include /usr/share/dpkg/pkg-info.mk
+
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -33,8 +35,10 @@ bin_priority := 28
# way. So far that's always been true. If it becomes false, some of
# the values below will have to be set manually.
-src_name := $(shell dpkg-parsechangelog -S source)
-debian_ver := $(shell dpkg-parsechangelog -S version)
+# From /usr/share/dpkg/pkg-info.mk
+src_name := $(DEB_SOURCE)
+debian_ver := $(DEB_VERSION)
+
major_ver := $(shell echo $(debian_ver) | sed 's/\..*//')
# Everything before the last '-' (21.3, 21.3a, 21.3+1, etc.)