summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Browning <rlb@defaultvalue.org>2011-04-09 20:41:52 -0500
committerSean Whitton <spwhitton@spwhitton.name>2024-02-26 12:20:24 +0800
commitecd4eeb3cd8350d75264ec7d5d49579e5b687b7a (patch)
treea3f42e3a9d88137256ea9d6be66af4913ff9e182
parent40c7c384491dc86c532080b63e62ec8a2a1ab6b6 (diff)
Adjust the build system to handle the DFSG split.
This package contains the Emacs files that do not appear to satisfy the DFSG. Author: Rob Browning <rlb@defaultvalue.org> Added-by: Rob Browning <rlb@defaultvalue.org> Status: new
-rw-r--r--doc/misc/Makefile.in20
1 files changed, 3 insertions, 17 deletions
diff --git a/doc/misc/Makefile.in b/doc/misc/Makefile.in
index 2841916dc89..082068c56c8 100644
--- a/doc/misc/Makefile.in
+++ b/doc/misc/Makefile.in
@@ -68,7 +68,7 @@ DOCMISC_W32 = @DOCMISC_W32@
## Info files to build and install on all platforms.
INFO_COMMON = auth autotype bovine calc ccmode cl dbus dired-x \
- ebrowse ede ediff edt efaq eglot eieio emacs-gnutls \
+ ebrowse ede ediff edt eglot eieio emacs-gnutls \
emacs-mime epa erc ert eshell eudc eww flymake forms gnus \
htmlfontify idlwave ido info.info mairix-el message mh-e \
modus-themes newsticker nxml-mode octave-mode org pcl-cvs pgg \
@@ -82,7 +82,7 @@ INFO_INSTALL = $(INFO_COMMON) $(DOCMISC_W32)
## Info files to build on current platform.
## This is all of them, even though they might not all get installed,
## because the info files are pre-built in release tarfiles.
-INFO_TARGETS = $(INFO_COMMON) efaq-w32
+INFO_TARGETS = $(INFO_COMMON)
## Some manuals have their source in .org format.
## This is discouraged because the .texi files it generates
@@ -186,7 +186,7 @@ $(foreach ifile,$(filter-out info.info,$(INFO_TARGETS)),$(eval $(call info_templ
## Extra dependencies.
## FIXME Updating this list manually is unreliable.
-need_emacsver = calc cl dired-x efaq efaq-w32 erc forms ido \
+need_emacsver = calc cl dired-x erc forms ido \
newsticker reftex remember use-package woman
need_emacsver_prefix = $(addprefix ${buildinfodir}/,${need_emacsver})
@@ -202,20 +202,6 @@ ${buildinfodir}/ccmode.info: \
${srcdir}/cc-mode.texi ${gfdl} ${style} | ${buildinfodir}
$(AM_V_GEN)$(MAKEINFO) $(MAKEINFO_OPTS) $(INFO_OPTS) -o $@ $<
-## efaq, efaq_w32 do not depend on gfdl.
-## Maybe we can use .SECONDEXPANSION for this.
-${buildinfodir}/efaq%.info: ${srcdir}/efaq%.texi ${style} | ${buildinfodir}
- $(AM_V_GEN)$(MAKEINFO) $(MAKEINFO_OPTS) $(INFO_OPTS) -o $@ $<
-
-efaq%.dvi: ${srcdir}/efaq%.texi
- $(ENVADD) $(TEXI2DVI) $<
-
-efaq%.pdf: ${srcdir}/efaq%.texi
- $(ENVADD) $(TEXI2PDF) $<
-
-efaq%.html: ${srcdir}/efaq%.texi
- $(AM_V_GEN)$(MAKEINFO) $(MAKEINFO_OPTS) $(HTML_OPTS) -o $@ $<
-
${buildinfodir}/emacs-mime.info emacs-mime.html: EXTRA_OPTS = --enable-encoding
gnus_deps = ${srcdir}/gnus.texi ${srcdir}/gnus-faq.texi ${gfdl} ${style}