summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2023-12-01 21:16:25 -0800
committerVagrant Cascadian <vagrant@reproducible-builds.org>2023-12-01 21:18:17 -0800
commit6e3e6b98bfde2aa55d2379cc3e45365aa9d21ca4 (patch)
tree7569d858fedaee9b67995530e7f45e30f510a23b
parenteafe9badb01bc217563ff6ba5a4e006268d61787 (diff)
Commit Debian 3.0 (quilt) metadata
[dgit (10.7+deb12u2) quilt-fixup]
-rw-r--r--debian/patches/fix-cross-building-by-using-ac_check_siz.patch67
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/srcmakefile.am-do-not-embed-the-build-us.patch22
3 files changed, 91 insertions, 0 deletions
diff --git a/debian/patches/fix-cross-building-by-using-ac_check_siz.patch b/debian/patches/fix-cross-building-by-using-ac_check_siz.patch
new file mode 100644
index 0000000..b4dfe7b
--- /dev/null
+++ b/debian/patches/fix-cross-building-by-using-ac_check_siz.patch
@@ -0,0 +1,67 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Date: Sat, 4 Jan 2020 15:09:24 +0100
+X-Dgit-Generated: 0.20.7-3 85ea69964a1004eb97d87558256b9ec37f5c9156
+Subject: Fix cross building by using AC_CHECK_SIZEOF instead of AC_TRY_RUN
+
+(Closes: #948138)
+
+gentoo fails to cross build from source, becasue it uses AC_TRY_RUN to
+figure out whether it needs _FILE_OFFSET_BITS. This can be implemented
+using a cross-compatible AC_CHECK_SIZEOF though.
+
+---
+
+diff --git a/configure.ac b/configure.ac
+index 393665b..516eeb1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -75,40 +75,17 @@ fi
+ # We do this in two steps: first figure out struct stat's st_size member's size for a "plain
+ # compile, and it that's just 32 we try again with _FILE_OFFSET_BITS=64 defined. If that works,
+ # we simply build gentoo with it and hope for the best.
+-AC_MSG_CHECKING([number of bits in st_size field])
+-bits="test failed"
+-# Put the entire testing program into a variable, for easier re-use below.
+-bitstest=`cat <<TESTPROG_EOF
+- #include <limits.h>
+- #include <stdio.h>
+- #include <stdlib.h>
+- #include <sys/types.h>
+- #include <sys/stat.h>
+- #include <unistd.h>
+-
+- int main(void)
+- {
+- struct stat stbuf;
+- FILE *out;
+-
+- if((out = fopen("conftest.statbits", "wt")) != NULL)
+- {
+- fprintf(out, "%d\n", CHAR_BIT * sizeof stbuf.st_size);
+- fclose(out);
+- }
+- exit(out != NULL ? EXIT_SUCCESS : EXIT_FAILURE);
+- }
+-TESTPROG_EOF`
+-AC_TRY_RUN([$bitstest], bits=`cat conftest.statbits`)
+-AC_MSG_RESULT([$bits])
+-if test "x$bits" = "x32" ; then
+- AC_MSG_CHECKING([again, with -D_FILE_OFFSET_BITS=64])
++AC_CHECK_SIZEOF([stbuf.st_size],,[AC_INCLUDES_DEFAULT
++#include <limits.h>
++struct stat stbuf;])
++AS_IF([test "$ac_cv_sizeof_stbuf_st_size" = 4],[
+ oldflags=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
+- bits="test failed"
+- AC_TRY_RUN([$bitstest], bits=`cat conftest.statbits`, , CPPFLAGS=$oldflags)
+- AC_MSG_RESULT([$bits])
+-fi
++ AC_CHECK_SIZEOF([stbuf64.st_size],,[AC_INCLUDES_DEFAULT
++#include <limits.h>
++struct stat stbuf64;])
++ AS_IF([test "$ac_cv_sizeof_stbuf64_st_size" = 8],,CPPFLAGS=$oldflags)
++])
+
+ # Check if the math library needs to be linked to explicitly in order to
+ # get the pow() function.
diff --git a/debian/patches/series b/debian/patches/series
index 5c5f374..c91d9a1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,5 @@
changed-default-dir-icons.patch
dpkg-buildflags.patch
change-config-directory-files.patch
+fix-cross-building-by-using-ac_check_siz.patch
+srcmakefile.am-do-not-embed-the-build-us.patch
diff --git a/debian/patches/srcmakefile.am-do-not-embed-the-build-us.patch b/debian/patches/srcmakefile.am-do-not-embed-the-build-us.patch
new file mode 100644
index 0000000..2fc1cf6
--- /dev/null
+++ b/debian/patches/srcmakefile.am-do-not-embed-the-build-us.patch
@@ -0,0 +1,22 @@
+From: Vagrant Cascadian <vagrant@reproducible-builds.org>
+Date: Wed, 16 Nov 2022 23:33:50 +0000
+X-Dgit-Generated: 0.20.7-3 a038bd40bd7afb79b83c980a8e724a8fa0f6877b
+Subject: src/Makefile.am: Do not embed the build user's home directory
+
+(Closes: #1024284)
+
+---
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index eb0194c..07bd08b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -203,7 +203,7 @@ localedir=@localedir@
+
+ AM_CFLAGS=@GENTOO_CFLAGS@ @GTK_CFLAGS@ -I../widgets \
+ -DPATH_CFG=\"$(sysconfdir)\" \
+- -DPATH_GRC=\"$$HOME/\" \
++ -DPATH_GRC=\"/nonexistent/\" \
+ -DPATH_ICN=\"$(datadir)/gentoo/icons\"\
+ -DLOCALEDIR=\"$(localedir)\"
+