summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@ubuntu.com>2022-08-22 12:15:44 +0100
committerColin Watson <cjwatson@ubuntu.com>2022-08-22 12:15:44 +0100
commit497a84008d1d3c2afed54ef26b07ec45e90a03de (patch)
tree8ecdc5cf50babcec964c8814117dbbeb8204711c
parent7f8f1ab587733eb2100f5db69e57cac25cf6379f (diff)
Switch from nose to pytest
nose is deprecated, so stop using it in the packaging.
-rw-r--r--debian/changelog4
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
3 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 674b14e..e7d6df9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,12 @@
git-build-recipe (0.3.7) UNRELEASED; urgency=medium
+ [ Debian Janitor ]
* Use secure copyright file specification URI.
* Remove unnecessary X-Python{,3}-Version field in debian/control.
+ [ Colin Watson ]
+ * Switch from nose to pytest.
+
-- Debian Janitor <janitor@jelmer.uk> Fri, 20 Dec 2019 13:47:13 +0000
git-build-recipe (0.3.6) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index aeb453f..165655a 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: vcs
Priority: optional
Maintainer: Colin Watson <cjwatson@ubuntu.com>
Standards-Version: 3.9.7
-Build-Depends: debhelper (>= 9), dh-python, python3 (>= 3.1.2-8~), python3-setuptools, python3-dateutil, python3-debian, python3-testtools, python3-fixtures, python3-nose, devscripts, git, pristine-tar, quilt
+Build-Depends: debhelper (>= 9), dh-python, python3 (>= 3.1.2-8~), python3-setuptools, python3-dateutil, python3-debian, python3-testtools, python3-fixtures, python3-pytest, devscripts, git, pristine-tar, quilt
Homepage: https://launchpad.net/git-build-recipe
Vcs-Git: https://git.launchpad.net/git-build-recipe
Vcs-Browser: https://git.launchpad.net/git-build-recipe
diff --git a/debian/rules b/debian/rules
index 4a74de8..45685ce 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,7 @@
#! /usr/bin/make -f
+
+export PYBUILD_TEST_PYTEST := 1
+
%:
dh $@ --with python3 --buildsystem pybuild