summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKentaro Hayashi <hayashi@clear-code.com>2020-04-29 15:14:19 +0900
committerSimon McVittie <smcv@debian.org>2020-08-19 09:26:08 +0100
commit691155da4310f8b7f62c9a0d6d3ea2609c6fb32f (patch)
treeee69c3f253ccc05299f10e477f91546fa96729b7
parent70902e2be05f34c2db8beaff6a67bf68590ed7d1 (diff)
Check for ayatana-appindicator instead of deprecated libappindicator
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=956768 Forwarded: no Gbp-Pq: Name Check-for-ayatana-appindicator-instead-of-deprecated-liba.patch
-rw-r--r--configure.ac30
-rw-r--r--src/tray-icon2.c2
2 files changed, 16 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 8b7c9d1..d52815e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -363,27 +363,27 @@ fi
APPINDICATOR_REQUIRED=0.3
-AC_ARG_ENABLE(appindicator,
- AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for application indicators ]),
- [enable_appindicator=$enableval],
- [enable_appindicator="auto"])
-
-if test x$enable_appindicator = xauto ; then
- PKG_CHECK_EXISTS([appindicator-0.1 >= $APPINDICATOR_REQUIRED],
- enable_appindicator="yes",
- enable_appindicator="no")
+AC_ARG_ENABLE(ayatana-appindicator,
+ AS_HELP_STRING([--enable-appindicator[=@<:@no/auto/yes@:>@]],[Build support for ayatana application indicators ]),
+ [enable_ayatana_appindicator=$enableval],
+ [enable_ayatana_appindicator="auto"])
+
+if test x$enable_ayatana_appindicator = xauto ; then
+ PKG_CHECK_EXISTS([ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED],
+ enable_ayatana_appindicator="yes",
+ enable_ayatana_appindicator="no")
fi
-if test x$enable_appindicator = xyes ; then
- PKG_CHECK_EXISTS([appindicator-0.1 >= $APPINDICATOR_REQUIRED],,
- AC_MSG_ERROR([appindicator-0.1 is not installed]))
+if test x$enable_ayatana_appindicator = xyes ; then
+ PKG_CHECK_EXISTS([ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED],,
+ AC_MSG_ERROR([ayatana-appindicator-0.1 is not installed]))
PKG_CHECK_MODULES(APP_INDICATOR,
- appindicator-0.1 >= $APPINDICATOR_REQUIRED)
+ ayatana-appindicator-0.1 >= $APPINDICATOR_REQUIRED)
AC_SUBST(APP_INDICATOR_CFLAGS)
AC_SUBST(APP_INDICATOR_LIBS)
AC_DEFINE(HAVE_APP_INDICATOR, 1, [Have AppIndicator])
fi
-AM_CONDITIONAL(HAVE_APP_INDICATOR, test x"$enable_appindicator" = xyes)
+AM_CONDITIONAL(HAVE_APP_INDICATOR, test x"$enable_ayatana_appindicator" = xyes)
AC_ARG_ENABLE([shave],
[ --disable-shave Use shave output cleaner when building.],
@@ -524,7 +524,7 @@ if test x${enable_mmkeys} = xyes; then
else
echo "Multimedia keys support is: disabled"
fi
-if test x"$enable_appindicator" = xyes; then
+if test x"$enable_ayatana_appindicator" = xyes; then
echo "AppIndicator Support is: enabled"
else
echo "AppIndicator Support is: disabled"
diff --git a/src/tray-icon2.c b/src/tray-icon2.c
index 561971a..9d7de32 100644
--- a/src/tray-icon2.c
+++ b/src/tray-icon2.c
@@ -36,7 +36,7 @@
#define TRAY_ICON2_ID "tray-icon2"
#ifdef HAVE_APP_INDICATOR
- #include <libappindicator/app-indicator.h>
+ #include <libayatana-appindicator/app-indicator.h>
AppIndicator *indicator;
#endif