summaryrefslogtreecommitdiff
path: root/debian/patches/meson-drop-unused-argument-for-i18n.merge_file.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/meson-drop-unused-argument-for-i18n.merge_file.patch')
-rw-r--r--debian/patches/meson-drop-unused-argument-for-i18n.merge_file.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/debian/patches/meson-drop-unused-argument-for-i18n.merge_file.patch b/debian/patches/meson-drop-unused-argument-for-i18n.merge_file.patch
new file mode 100644
index 0000000..fda2419
--- /dev/null
+++ b/debian/patches/meson-drop-unused-argument-for-i18n.merge_file.patch
@@ -0,0 +1,51 @@
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 24 Jan 2022 11:13:54 +0000
+Subject: meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/appdata/meson.build:3:5: ERROR: Function does not take positional arguments.
+data/meson.build:6:5: ERROR: Function does not take positional arguments.
+data/meson.build:49:5: ERROR: Function does not take positional arguments.
+
+Origin: upstream, 40.1, commit:cf3f8a67cd6f3059c555ed9cf0f5fba10abb7f68
+Bug-Debian: https://bugs.debian.org/1005491
+---
+ data/appdata/meson.build | 2 +-
+ data/meson.build | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/data/appdata/meson.build b/data/appdata/meson.build
+index ef95c85..65a044f 100644
+--- a/data/appdata/meson.build
++++ b/data/appdata/meson.build
+@@ -1,6 +1,6 @@
+ appdata_conf = configuration_data()
+ appdata_conf.set('application_id', application_id)
+-appdata_file = i18n.merge_file('appdata',
++appdata_file = i18n.merge_file(
+ input: configure_file(
+ input: 'org.gnome.Dictionary.appdata.xml.in.in',
+ output: 'org.gnome.Dictionary.appdata.xml.in',
+diff --git a/data/meson.build b/data/meson.build
+index 1723c8f..4db85ee 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -3,7 +3,7 @@ subdir('appdata')
+ desktop_conf = configuration_data()
+ desktop_conf.set('icon', application_id)
+ desktop_conf.set('application_id', application_id)
+-desktop_file = i18n.merge_file('desktop',
++desktop_file = i18n.merge_file(
+ input: configure_file(
+ input: 'org.gnome.Dictionary.desktop.in.in',
+ output: 'org.gnome.Dictionary.desktop.in',
+@@ -46,7 +46,7 @@ sources = [
+ ]
+
+ foreach s: sources
+- i18n.merge_file('sources',
++ i18n.merge_file(
+ input: '@0@.in'.format(s),
+ output: s,
+ install: true,