summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatteo F. Vescovi <mfv@debian.org>2020-10-05 00:25:02 +0200
committerMatteo F. Vescovi <mfv@debian.org>2020-10-05 00:25:02 +0200
commitf86820f9182f57476774ca0a96c274241ae3ce59 (patch)
tree1c5fbc5bf37fc2a8a9d743b1b912521c0b263317
parent0c4e3cc35a823dd0a7463092f25a2d080201bea4 (diff)
Initial packaging skeleton
-rw-r--r--debian/changelog5
-rw-r--r--debian/control30
-rw-r--r--debian/copyright34
-rw-r--r--debian/docs1
-rw-r--r--debian/install1
-rw-r--r--debian/patches/0001-Fix_MenuItem.patch32
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules10
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch6
10 files changed, 121 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..2e197d9
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+gnome-shell-extension-freon (42+dfsg-1) UNRELEASED; urgency=medium
+
+ * Initial release (Closes: #999999)
+
+ -- Matteo F. Vescovi <mfv@debian.org> Sun, 04 Oct 2020 23:45:11 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..685deca
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,30 @@
+Source: gnome-shell-extension-freon
+Section: gnome
+Priority: optional
+Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
+Uploaders: Matteo F. Vescovi <mfv@debian.org>
+Build-Depends:
+ debhelper-compat (= 13),
+ libglib2.0-dev
+Standards-Version: 4.5.0
+Rules-Requires-Root: no
+Homepage: https://github.com/UshakovVasilii/gnome-shell-extension-freon
+Vcs-Browser: https://salsa.debian.org/gnome-team/shell-extensions/gnome-shell-extension-freon
+Vcs-Git: https://salsa.debian.org/gnome-team/shell-extensions/gnome-shell-extension-freon.git
+
+Package: gnome-shell-extension-freon
+Architecture: all
+Depends:
+ gnome-shell (>= 3.38),
+ gnome-shell (<< 40~),
+ ${misc:Depends},
+ ${shlibs:Depends}
+Description: GNOME Shell Extension for Sensors
+ Freon is a fork of gnome-shell-extension-sensors, a GNOME Shell
+ extension for displaying the temperature of your CPU, hard disk,
+ solid state, and video card (NVIDIA, Catalyst, and Bumblebee
+ supported), as well as power supply voltage, and fan speed. You can
+ choose which HDD/SSD or other devices to include, what temperature
+ units to use, and how often to refresh the sensors readout, and they
+ will appear in the GNOME Shell top bar. For the GPU temperature, you
+ may need to install the vendor's driver for best results.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..295c422
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,34 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: GNOME Shell Extension Freon
+Source: https://github.com/UshakovVasilii/gnome-shell-extension-freon
+Files-Excluded:
+ .gitignore
+ deploy.sh
+ img
+ LICENSE
+ makeZip.sh
+
+Files: *
+Copyright: 2020 Vasilii Ushakov <UshakovVasilii@gmail.com>
+License: GPL-2+
+
+Files: debian/*
+Copyright: 2020 Matteo F. Vescovi <mfv@debian.org>
+License: GPL-2+
+
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <https://www.gnu.org/licenses/>
+ .
+ On Debian systems, the complete text of the GNU General
+ Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..b43bf86
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..d13db27
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+freon@UshakovVasilii_Github.yahoo.com/ usr/share/gnome-shell/extensions
diff --git a/debian/patches/0001-Fix_MenuItem.patch b/debian/patches/0001-Fix_MenuItem.patch
new file mode 100644
index 0000000..e87a5cd
--- /dev/null
+++ b/debian/patches/0001-Fix_MenuItem.patch
@@ -0,0 +1,32 @@
+From: "Matteo F. Vescovi" <mfv@debian.org>
+Date: Mon, 5 Oct 2020 00:12:24 +0200
+Subject: Fix_MenuItem
+
+---
+ freon@UshakovVasilii_Github.yahoo.com/freonItem.js | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/freon@UshakovVasilii_Github.yahoo.com/freonItem.js b/freon@UshakovVasilii_Github.yahoo.com/freonItem.js
+index 05d623d..84c4c89 100644
+--- a/freon@UshakovVasilii_Github.yahoo.com/freonItem.js
++++ b/freon@UshakovVasilii_Github.yahoo.com/freonItem.js
+@@ -1,6 +1,7 @@
+ const GObject = imports.gi.GObject;
+ const PopupMenu = imports.ui.popupMenu;
+ const St = imports.gi.St;
++const Clutter = imports.gi.Clutter;
+
+ var FreonItem = GObject.registerClass(class FreonItem extends PopupMenu.PopupBaseMenuItem {
+
+@@ -10,9 +11,9 @@ var FreonItem = GObject.registerClass(class FreonItem extends PopupMenu.PopupBas
+ this._key = key;
+ this._gIcon = gIcon;
+
+- this._labelActor = new St.Label({text: displayName ? displayName : label});
++ this._labelActor = new St.Label({text: displayName ? displayName : label, x_align: Clutter.ActorAlign.CENTER, x_expand: true});
+ this.actor.add(new St.Icon({ style_class: 'popup-menu-icon', gicon : gIcon}));
+- this.actor.add(this._labelActor, {x_fill: true, expand: true});
++ this.actor.add_child(this._labelActor);
+ this._valueLabel = new St.Label({text: value});
+ this.actor.add(this._valueLabel);
+ }
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..4fd9449
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Fix_MenuItem.patch
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ea98469
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+PACKAGE=freon@UshakovVasilii_Github.yahoo.com
+
+%:
+ dh $@
+
+override_dh_auto_build:
+ glib-compile-schemas $(PACKAGE)/schemas
+ dh_auto_build
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..9e0915c
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,6 @@
+version=4
+opts="dversionmangle=s/\+dfsg.*//, \
+filenamemangle=s/.+\/EGO-?(\d\S+)\.tar\.gz/gnome-shell-extension-freon-$1\.tar\.gz/, \
+repack, \
+repacksuffix=+dfsg" \
+https://github.com/UshakovVasilii/gnome-shell-extension-freon/tags .*/EGO-?(\d\S+)\.tar\.gz