summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2022-07-07 15:28:15 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2022-07-07 15:28:17 +0100
commit9dce60f9fb09c634f112fd4d113a40c60e7ec507 (patch)
tree60bbd5123eea199d7889e9b76e8e6d11f37c38ea
parentaa3992fb5ffe43760a4d469e62aef5f1f2f4f3ed (diff)
Fix stats logging.
-rw-r--r--debian/changelog4
-rw-r--r--statemc.c8
2 files changed, 6 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 1128763..0c865e5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
-innduct (2.1~~iwj2) unstable; urgency=medium
+innduct (2.1~~iwj3) unstable; urgency=medium
- * Fix stats logging and log missing better.
+ * Fix stats logging.
* Fix many bugs and compiler warnings.
-- Ian Jackson <ijackson@chiark.greenend.org.uk> Thu, 07 Jul 2022 11:24:20 +0100
diff --git a/statemc.c b/statemc.c
index 2e49692..fb37246 100644
--- a/statemc.c
+++ b/statemc.c
@@ -239,8 +239,8 @@ static void notice_processed_counts(Counts *counts, int completed,
: masprintf("%s","");
notice("%s %s read=%d (+bl=%d,+err=%d)%s%s missing=%d"
- " offered=%d (ch=%d,nc=%d;mi=%d)"
- " accepted=%d (ch=%d,nc=%d;mi=%d)"
+ " offered=%d (ch=%d,nc=%d)"
+ " accepted=%d (ch=%d,nc=%d)"
RESULT_COUNTS(RCI_NOTHING, RCI_TRIPLE_FMT)
,
completed?"completed":"processed", what,
@@ -248,9 +248,9 @@ static void notice_processed_counts(Counts *counts, int completed,
counts->events[read_err],
inprog, autodefer, counts->events[nooffer_missing],
CNT(Unchecked,sent) + CNT(Unsolicited,sent)
- , CNT(Unchecked,sent), CNT(Unsolicited,sent), CNT(Unsolicited,missing),
+ , CNT(Unchecked,sent), CNT(Unsolicited,sent),
CNT(Wanted,accepted) + CNT(Wanted,accepted)
- , CNT(Wanted,accepted), CNT(Wanted,accepted), CNT(Wanted,missing)
+ , CNT(Wanted,accepted), CNT(Wanted,accepted)
RESULT_COUNTS(RCI_NOTHING, RCI_TRIPLE_VALS)
);