summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOsamu Aoki <osamu@debian.org>2022-08-02 01:45:37 +0900
committerOsamu Aoki <osamu@debian.org>2022-09-18 19:39:25 +0900
commit6f27543df638ba8cc7665199d01248a5b9719130 (patch)
treec7d1ccd4478fcf1cbb4989fbf5f7fcc1041185a4
parent5b78b48f569bb58623389b9924d4a9b9ccf77201 (diff)
Patch: Rename intercept -> interception
Upstream build system is modified to rename the binary executable. This is to avoid collision with bear package command: intercept -> interception Signed-off-by: Osamu Aoki <osamu@debian.org>
-rw-r--r--CMakeLists.txt10
-rw-r--r--debian/patches/0001-Rename-intercept-interception.patch43
-rw-r--r--debian/patches/series1
3 files changed, 5 insertions, 49 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af5fd82..efd5a8f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,10 +13,10 @@ target_include_directories(udevmon PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
target_compile_options(udevmon PRIVATE -Wall -Wextra -pedantic -std=c++11)
target_link_libraries(udevmon evdev udev yaml-cpp)
-add_executable(intercept intercept.c)
-target_include_directories(intercept PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
-target_compile_options(intercept PRIVATE -Wall -Wextra)
-target_link_libraries(intercept evdev)
+add_executable(interception intercept.c)
+target_include_directories(interception PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
+target_compile_options(interception PRIVATE -Wall -Wextra)
+target_link_libraries(interception evdev)
add_executable(uinput uinput.cpp)
target_include_directories(uinput PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
@@ -29,6 +29,6 @@ target_compile_options(mux PRIVATE -Wall -Wextra -pedantic -std=c++11 -DBOOST_DA
target_link_libraries(mux Threads::Threads rt)
install(TARGETS udevmon RUNTIME DESTINATION bin)
-install(TARGETS intercept RUNTIME DESTINATION bin)
+install(TARGETS interception RUNTIME DESTINATION bin)
install(TARGETS uinput RUNTIME DESTINATION bin)
install(TARGETS mux RUNTIME DESTINATION bin)
diff --git a/debian/patches/0001-Rename-intercept-interception.patch b/debian/patches/0001-Rename-intercept-interception.patch
deleted file mode 100644
index 9eb5fd5..0000000
--- a/debian/patches/0001-Rename-intercept-interception.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 3b0dac2200060d7e2887e326d9f7936c82ebb52c Mon Sep 17 00:00:00 2001
-From: Osamu Aoki <osamu@debian.org>
-Date: Tue, 2 Aug 2022 01:45:37 +0900
-Subject: [PATCH 1/1] Rename: intercept -> interception
-
-Binary executable name is renamed to avoid collision with bear
-package: intercept -> interception
-
-Signed-off-by: Osamu Aoki <osamu@debian.org>
----
- CMakeLists.txt | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index af5fd82..efd5a8f 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -13,10 +13,10 @@ target_include_directories(udevmon PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
- target_compile_options(udevmon PRIVATE -Wall -Wextra -pedantic -std=c++11)
- target_link_libraries(udevmon evdev udev yaml-cpp)
-
--add_executable(intercept intercept.c)
--target_include_directories(intercept PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
--target_compile_options(intercept PRIVATE -Wall -Wextra)
--target_link_libraries(intercept evdev)
-+add_executable(interception intercept.c)
-+target_include_directories(interception PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
-+target_compile_options(interception PRIVATE -Wall -Wextra)
-+target_link_libraries(interception evdev)
-
- add_executable(uinput uinput.cpp)
- target_include_directories(uinput PRIVATE ${LIBEVDEV_INCLUDE_DIRS})
-@@ -29,6 +29,6 @@ target_compile_options(mux PRIVATE -Wall -Wextra -pedantic -std=c++11 -DBOOST_DA
- target_link_libraries(mux Threads::Threads rt)
-
- install(TARGETS udevmon RUNTIME DESTINATION bin)
--install(TARGETS intercept RUNTIME DESTINATION bin)
-+install(TARGETS interception RUNTIME DESTINATION bin)
- install(TARGETS uinput RUNTIME DESTINATION bin)
- install(TARGETS mux RUNTIME DESTINATION bin)
---
-2.35.1
-
diff --git a/debian/patches/series b/debian/patches/series
index 7c2216d..e69de29 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +0,0 @@
-0001-Rename-intercept-interception.patch